Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985644 - [virtio-win][vioscsi]Shutdown guest got 9f bsod after the guest install virtio scsi driver.
Summary: [virtio-win][vioscsi]Shutdown guest got 9f bsod after the guest install virti...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 7.1
Assignee: John Snow
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 896495
TreeView+ depends on / blocked
 
Reported: 2013-07-18 02:19 UTC by Min Deng
Modified: 2016-01-22 21:24 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-22 21:24:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Min Deng 2013-07-18 02:19:15 UTC
Description of problem:
Shut down guest got 9f error after the guest install virtio scsi driver. 

Version-Release number of selected component (if applicable):
build 65
rhel 7 host -qemu-kvm-1.5.1-2.el7.x86_64
            -kernel-3.10.0-1.el7.x86_64

How reproducible:
2 times.
I tried two images ,
One cannot reproduce the issue another can reproduce it.
The second one,
qcow3 format

Steps to Reproduce:
1.install a guest with system ide driver ,and install virtio scsi driver to data disk,and then change system disk to virtio scsi at last.boot up guest again.
CLI1,
/usr/libexec/qemu-kvm -m 6G -smp 4 -cpu Opteron_G3,family=0xf -usb -device usb-tablet -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=00:1c:3f:21:46:31 -uuid cccc6a20-2351-4762-a654-b7990c16d720 -vnc :1 -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -device isa-debugcon,iobase=0x402,chardev=seabios_debug -drive file=win7-32-again.qcow3,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,id=scsi-disk0,format=qcow2 -drive file=disk1.qcow3,if=none,media=disk,format=qcow2,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk1 -drive file=disk2.qcow3,if=none,media=disk,format=qcow2,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk2 -drive file=disk3.qcow3,if=none,media=disk,format=qcow2,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk3 -drive file=disk4.qcow3,if=none,media=disk,format=qcow2,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk4,readonly=on -device virtio-scsi-pci,id=bus1 -device scsi-hd,bus=bus1.0,drive=scsi-disk0,id=disk,serial=test,bootindex=1 -device scsi-hd,bus=bus1.0,drive=scsi-disk1,id=disk1,serial=test1 -device scsi-hd,bus=bus1.0,drive=scsi-disk2,id=disk2,serial=test2 -device scsi-hd,bus=bus1.0,drive=scsi-disk3,id=disk3,serial=test3 -device scsi-hd,bus=bus1.0,drive=scsi-disk4,id=disk4,serial=test4 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -qmp tcp:0:1111,server,nowait -device virtio-scsi-pci,id=bus2 -device scsi-hd,bus=bus2.0,drive=scsi-disk5,id=disk5,serial=test5 -drive file=disk5.qcow3,if=none,media=disk,format=qcow2,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk5 -spice disable-ticketing,port=5931 -vga qxl -no-kvm-pit-reinjection -chardev socket,id=abc,path=/tmp/tt,server,nowait -mon chardev=abc,mode=readline -device ahci,id=ahci0,multifunction=on -drive file=/home/sata.qcow2,if=none,id=drive-system-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop -device ide-drive,bus=ahci0.0,drive=drive-system-disk,id=system-disk,ver=mdeng -drive file=ide.qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0
2.Check the driver status 
  the driver was installed correctly 
3.shut down the guest

Actual results:
It lasted  long time and finally got 9f issue.
Expected results:
The guest can shut down successfully.
Additional info:

Comment 3 Min Deng 2013-07-18 02:38:20 UTC
After I remove sata disk,the guest works well.Thanks

Comment 4 Mike Cao 2013-07-18 03:28:17 UTC
(In reply to dengmin from comment #3)
> After I remove sata disk,the guest works well.Thanks

This should means there is some bugs in AHCI ,I don't think it is the reason to close this bug

Comment 6 Sibiao Luo 2013-07-18 03:50:17 UTC
windows guest shoud be installed under q35(or with ahci) first when need to use q35, not to use a windows guest under q35(or with ahci) while it was installed under pc-** machine type.(BZ#894285) 

Best Regards,
sluo

Comment 7 Min Deng 2013-07-18 08:57:16 UTC
(In reply to dengmin from comment #3)
> After I remove sata disk,the guest works well.Thanks

The issue cannot be reproduced while removing this from CLI 
 "-device ahci,id=ahci0,multifunction=on -drive file=/home/sata.qcow2,if=none,id=drive-system-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop -device ide-drive,bus=ahci0.0,drive=drive-system-disk,id=system-disk,ver=mdeng -drive file=ide.qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0"

Comment 10 Ronen Hod 2013-12-12 14:43:55 UTC
So far we do not support AHCI without Q35, although it is doable.
Deferring to 7.1
CC Gerd and Kevin. The bug will eventually be assigned to one of them.

Comment 13 John Snow 2015-07-01 22:13:29 UTC
I'm trying to reproduce this but I'm having troubles recreating the problem as you saw it. I know this is bug is very old, but can you help clarify it for me?

I'm also confused about which drive we are booting from and what the installation process looked like. You've got eight drives, and you installed Windows "using the IDE driver," so I assume that means you installed Windows 7 to "ide.qcow2," is that correct? 

I'm confused because "win7-32-again.qcow2" is currently assigned to the first virtio bus, so I am not exactly sure which drives have windows on them, which should be bootable, etc.

Can you please clarify your steps to reproduce, by giving me *all* of the CLIs involved?

Example:

(1) Install Windows to [file.qcow2] using [CLI]
(2) Boot to the recently installed windows using [CLI2]
(3) Install the Virtio drivers, shut down
(4) Boot windows using [CLI3]
(5) Observe BSOD.

Thank you.

Comment 14 John Snow 2015-07-17 17:42:09 UTC
Can't reproduce, waiting for some confirmation. In the meantime, unassigning and moving to 7.3.

Comment 17 John Snow 2016-01-22 21:24:40 UTC
It looks like the bug does not reproduce on recent builds, so I am closing this for now. Please feel free to re-open if this happens to crop up again. Thank you for going through the trouble to re-verify.

Thanks,
--John S


Note You need to log in before you can comment on or make changes to this bug.