Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985228 - Can not synchronization the TUI between remote connection using ssh and local host
Summary: Can not synchronization the TUI between remote connection using ssh and local...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-17 06:52 UTC by wanghui
Modified: 2014-01-21 19:45 UTC (History)
14 users (show)

Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
If multiple admin sessions were opened, changed values which relied on Augeas (DNS and NTP settings principally) did not reflect changes between them without quitting the UI. This has been fixed by forcing a reload of cached Augeas values so it properly updates.
Clone Of:
Environment:
Last Closed: 2014-01-21 19:45:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0033 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-22 00:14:30 UTC
oVirt gerrit 17722 None None None Never

Description wanghui 2013-07-17 06:52:50 UTC
Description of problem:
When set the dns server in remote using ssh mode, it can not synchronization the TUI display to the local host and vice versa.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1732.el6
virt-node-3.0.0-3.999.20130716184106gitdb92e70.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clear install rhevh6.5.
2. Configure the network and enable ssh.
3. Remote connect to the host using ssh mode.
4. Change the dns server address in remote.
5. Check in local host and /etc/resolv.conf file.
6. Change the dns server address in local host.
7. Check in remote and /etc/resolv.conf file.

Actual results:
After step5&7, it is not synchronization in TUI between remote connection using ssh mode and local host. But the /etc/resolv.conf file is consistent.

Expected results:
After step5&7, it is consistent in TUI between remote connection using ssh mode and local host.

Additional info:

Comment 2 Ryan Barry 2013-08-14 19:20:37 UTC
A fix for this has been posted upstream.

Comment 5 wanghui 2013-10-10 07:36:37 UTC
Test version:
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
ovirt-node-3.0.1-3.el6.noarch

Test steps:
1. Clear install rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso.
2. Configure the network and enable ssh.
3. Remote connect to the host using ssh mode.
4. Change the dns server address in remote.
5. Check in local host and /etc/resolv.conf file.
6. Change the dns server address in local host.
7. Check in remote and /etc/resolv.conf file.

Test result:
1. It can synchronize the configuration between ssh and local.

So the bug is fixed in rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso. I will recheck it when I get official build later.

Comment 6 wanghui 2013-10-18 10:34:03 UTC
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6.noarch

Test steps:
1. Clear install rhev-hypervisor6-6.5-20131017.0.iso.
2. Configure the network and enable ssh.
3. Remote connect to the host using ssh mode.
4. Change the dns server address in remote.
5. Check in local host and /etc/resolv.conf file.
6. Change the dns server address in local host.
7. Check in remote and /etc/resolv.conf file.

Test result:
1. It can synchronize the configuration between ssh and local.

This bug is fixed in rhev-hypervisor6-6.5-20131017.0.iso. So change the bug's status from ON_QA to VERIFIED.

Comment 9 Cheryn Tan 2013-11-08 00:35:54 UTC
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 11 errata-xmlrpc 2014-01-21 19:45:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html


Note You need to log in before you can comment on or make changes to this bug.