Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985089 - java applets are not working in firefox on f19
Summary: java applets are not working in firefox on f19
Keywords:
Status: CLOSED DUPLICATE of bug 903406
Alias: None
Product: Fedora
Classification: Fedora
Component: icedtea-web
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: jiri vanek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-16 18:37 UTC by Garrett Mitchener
Modified: 2014-01-02 16:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-01 14:09:38 UTC


Attachments (Terms of Use)
export ICEDTEAPLUGIN_DEBUG=true; firefox >& firefox-java-log.txt & then visit java.com and try to load the test applet (deleted)
2013-07-16 18:37 UTC, Garrett Mitchener
no flags Details
java.stderr (deleted)
2013-07-30 20:16 UTC, Garrett Mitchener
no flags Details

Description Garrett Mitchener 2013-07-16 18:37:01 UTC
Created attachment 774444 [details]
export ICEDTEAPLUGIN_DEBUG=true; firefox >& firefox-java-log.txt & then visit java.com and try to load the test applet

Description of problem:

Java applets don't work in Firefox.

Version-Release number of selected component (if applicable):

firefox-22.0-1.fc19.i686
icedtea-web-1.4-2.fc19.i686
selinux-policy-3.12.1-63.fc19.noarch

How reproducible:

Every time.

Steps to Reproduce:

Using Firefox and icedtea-web: Go to http://www.java.com/ and click through "Do I have java" and "Verify java version" to get to 

http://java.com/en/download/installed.jsp?detect=jre

The applet doesn't appear.  I haven't been able to get any java applet to work.

Additional info:

The test applet at java.com doesn't appear on google-chrome either.  However, I can at least get into my university's Juniper VPN using google-chrome, and that involves an applet.

It might be a problem with icedtea-web, SELinux, or polkitd, but I'm having trouble narrowing it down.  

I'm filing this bug under firefox because I am getting Java applets to work on google-chrome.

Comment 1 Garrett Mitchener 2013-07-16 20:31:42 UTC
These applets work once I grant permission:

http://www.javakode.com/applets/

Maybe it has to do with signed vs. unsigned applets?

Comment 2 Deepak Bhole 2013-07-24 14:33:37 UTC
Hi Garrett. Yes, all applets now require permission to run, even unsigned ones. We did this in light of the recent barrage of Java security erratas.

So everything works for you if you grant the permissions?

Comment 3 Garrett Mitchener 2013-07-30 20:08:20 UTC
No.  The applet at 

http://java.com/en/download/installed.jsp?detect=jre

never asks for permission.  I get a gray rectangle in the browser window where the applet should go, and nothing more.

I get the same thing trying to log in to the Juniper VPN that my employer uses.

Comment 4 Garrett Mitchener 2013-07-30 20:15:33 UTC
Correction: If I first erase ~/.icedtea*/ then try to load the java.com test page, it does ask permission, remembers that I clicked "yes", then continues to fail as described.  I'll attach ~/.icedtea/log/java.stderr & java.stdout

Comment 5 Garrett Mitchener 2013-07-30 20:16:07 UTC
Created attachment 780830 [details]
java.stderr

Comment 6 Garrett Mitchener 2013-07-30 20:18:25 UTC
java.stdout is empty

Comment 7 Omair Majid 2013-07-30 20:19:18 UTC
I can confirm.

When I visit:
http://java.com/en/download/installed.jsp?detect=jre

I get a prompt asking me for confirmation to run the applet. When I grant the permissions, I get a grey box and nothing happens.

I tried again and when I deny the permissions, I get the standard icedtea errors displayed.

Comment 8 Deepak Bhole 2013-07-30 20:36:19 UTC
So it is a problem with the permission mechanism? Assigning to Adam to take a look.+

Comment 9 Omair Majid 2013-07-30 20:39:42 UTC
(In reply to Deepak Bhole from comment #8)
> So it is a problem with the permission mechanism?

Can't say. The applet just turns grey when I allow it to run.

Comment 10 Adam Domurad 2013-08-01 14:09:38 UTC
The applet is silently failing here after failing to go to a 'javascript:<some code>' URL. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 903406 ***


Note You need to log in before you can comment on or make changes to this bug.