Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985084 - On boot dhcpd service is in a failed state and has to be started
Summary: On boot dhcpd service is in a failed state and has to be started
Keywords:
Status: CLOSED DUPLICATE of bug 985385
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jiri Popelka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-16 18:22 UTC by Ian Neal
Modified: 2013-07-17 11:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-17 11:35:42 UTC


Attachments (Terms of Use)

Description Ian Neal 2013-07-16 18:22:17 UTC
Description of problem:
On boot dhcpd service is in a failed state and has to be started

Version-Release number of selected component (if applicable):
4.2.5-15

How reproducible:
Always

Steps to Reproduce:
1. Have a computer with two network cards
2. Configure dhcpd service to give out dhcp leases on one of the two cards
3. Boot up computer
4. Check status of dhcpd service using systemctl

Actual results:
dhcpd service is in a failed state
Have to start dhcpd service using systemctl

Expected results:
dhcpd service is in an active state

Additional info:
This worked without an issue in Fedora 17 using the same hardware.

Comment 1 Ian Neal 2013-07-16 18:28:18 UTC
messages log for failure:
Jul 16 18:02:17 brightwood dhcpd: 
Jul 16 18:02:17 brightwood dhcpd: No subnet declaration for em1 (no IPv4 address
es).
Jul 16 18:02:17 brightwood dhcpd: ** Ignoring requests on em1.  If this is not w
hat
Jul 16 18:02:17 brightwood dhcpd:    you want, please write a subnet declaration
Jul 16 18:02:17 brightwood dhcpd:    in your dhcpd.conf file for the network seg
ment
Jul 16 18:02:17 brightwood dhcpd:    to which interface em1 is attached. **
Jul 16 18:02:17 brightwood dhcpd: 
Jul 16 18:02:17 brightwood dhcpd: 
Jul 16 18:02:17 brightwood dhcpd: No subnet declaration for p2p1 (no IPv4 addres
ses).
Jul 16 18:02:17 brightwood dhcpd: ** Ignoring requests on p2p1.  If this is not 
what
Jul 16 18:02:17 brightwood dhcpd:    you want, please write a subnet declaration
Jul 16 18:02:17 brightwood dhcpd:    in your dhcpd.conf file for the network seg
ment
Jul 16 18:02:17 brightwood dhcpd:    to which interface p2p1 is attached. **
Jul 16 18:02:17 brightwood dhcpd: 
Jul 16 18:02:17 brightwood dhcpd: 
Jul 16 18:02:17 brightwood dhcpd: Not configured to listen on any interfaces!
Jul 16 18:02:17 brightwood dhcpd: 
Jul 16 18:02:17 brightwood dhcpd: This version of ISC DHCP is based on the relea
se available
Jul 16 18:02:17 brightwood dhcpd: on ftp.isc.org.  Features have been added and 
other changes
Jul 16 18:02:17 brightwood dhcpd: have been made to the base software release in
 order to make
Jul 16 18:02:17 brightwood dhcpd: it work better with this distribution.
Jul 16 18:02:17 brightwood dhcpd: 
Jul 16 18:02:17 brightwood dhcpd: Please report for this software via the Red Ha
t Bugzilla site:
Jul 16 18:02:17 brightwood dhcpd:     http://bugzilla.redhat.com
Jul 16 18:02:17 brightwood dhcpd: 
Jul 16 18:02:17 brightwood dhcpd: exiting.
Jul 16 18:02:17 brightwood systemd[1]: dhcpd.service: main process exited, code=
exited, status=1/FAILURE
Jul 16 18:02:17 brightwood systemd[1]: Unit dhcpd.service entered failed state.

messages log for start:
Jul 16 19:06:36 brightwood systemd[1]: Starting DHCPv4 Server Daemon...
Jul 16 19:06:36 brightwood systemd[1]: Started DHCPv4 Server Daemon.
Jul 16 19:06:36 brightwood dhcpd: Internet Systems Consortium DHCP Server 4.2.5
Jul 16 19:06:36 brightwood dhcpd: Copyright 2004-2013 Internet Systems Consortiu
m.
Jul 16 19:06:36 brightwood dhcpd: All rights reserved.
Jul 16 19:06:36 brightwood dhcpd: For info, please visit https://www.isc.org/sof
tware/dhcp/
Jul 16 19:06:36 brightwood dhcpd: Not searching LDAP since ldap-server, ldap-por
t and ldap-base-dn were not specified in the config file
Jul 16 19:06:36 brightwood dhcpd: Wrote 1 leases to leases file.
Jul 16 19:06:36 brightwood dhcpd: Listening on LPF/em1/90:b1:1c:57:e4:43/192.168
.1.0/24
Jul 16 19:06:36 brightwood dhcpd: Sending on   LPF/em1/90:b1:1c:57:e4:43/192.168
.1.0/24
Jul 16 19:06:36 brightwood dhcpd: 
Jul 16 19:06:36 brightwood dhcpd: No subnet declaration for p2p1 (192.168.0.7).
Jul 16 19:06:36 brightwood dhcpd: ** Ignoring requests on p2p1.  If this is not 
what
Jul 16 19:06:36 brightwood dhcpd:    you want, please write a subnet declaration
Jul 16 19:06:36 brightwood dhcpd:    in your dhcpd.conf file for the network seg
ment
Jul 16 19:06:36 brightwood dhcpd:    to which interface p2p1 is attached. **
Jul 16 19:06:36 brightwood dhcpd: 
Jul 16 19:06:36 brightwood dhcpd: Sending on   Socket/fallback/fallback-net

Comment 2 Jiri Popelka 2013-07-17 11:35:42 UTC

*** This bug has been marked as a duplicate of bug 985385 ***


Note You need to log in before you can comment on or make changes to this bug.