Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985081 - Unable to build JSS on F19
Summary: Unable to build JSS on F19
Keywords:
Status: CLOSED DUPLICATE of bug 847120
Alias: None
Product: Fedora
Classification: Fedora
Component: jss
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christina Fu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-16 18:15 UTC by Endi Sukma Dewata
Modified: 2013-07-17 08:01 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-17 08:01:33 UTC


Attachments (Terms of Use)
0001-Added-makefiles-for-Linux-3.8-3.16.patch (deleted)
2013-07-16 18:15 UTC, Endi Sukma Dewata
no flags Details | Diff

Description Endi Sukma Dewata 2013-07-16 18:15:31 UTC
Created attachment 774442 [details]
0001-Added-makefiles-for-Linux-3.8-3.16.patch

JSS failed to build on F19 due to missing Linux3.9.mk:

 ../coreconf/config.mk:71: ../coreconf/Linux3.9.mk: No such file or directory
 make: *** No rule to make target ../coreconf/Linux3.9.mk.  Stop.
 make: *** [../coreconf/Linux3.9.mk] Error 1
 make: Leaving directory `/root/rpmbuild/BUILD/jss-4.2.6/mozilla/security/coreconf'
 error: Bad exit status from /var/tmp/rpm-tmp.I0uj8K (%build)

Also there's a bogus date in the changelog:

 RPM build errors:
     bogus date in %changelog: Mon Feb 27 2007 Rob Crittenden <rcritten@redhat.com> 4.2.4-1
     Bad exit status from /var/tmp/rpm-tmp.I0uj8K (%build)

Per mharmsen's suggestion, attached is a patch to generate the makefiles for Linux 3.8 - 3.16 automatically.

Comment 1 Mat Booth 2013-07-17 08:01:33 UTC

*** This bug has been marked as a duplicate of bug 847120 ***


Note You need to log in before you can comment on or make changes to this bug.