Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 985043 - can't create snapshot, "vmSnapshot() takes exactly 3 arguments (4 given)"
Summary: can't create snapshot, "vmSnapshot() takes exactly 3 arguments (4 given)"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.3.0
Assignee: Arik
QA Contact: meital avital
URL:
Whiteboard: virt
: 982289 (view as bug list)
Depends On:
Blocks: 975946 980849
TreeView+ depends on / blocked
 
Reported: 2013-07-16 15:54 UTC by Aharon Canan
Modified: 2015-09-22 13:09 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-17 08:12:01 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
libvirt (deleted)
2013-07-16 15:55 UTC, Aharon Canan
no flags Details
engine (deleted)
2013-07-16 15:57 UTC, Aharon Canan
no flags Details
spm (deleted)
2013-07-16 16:01 UTC, Aharon Canan
no flags Details
hsm (deleted)
2013-07-16 16:03 UTC, Aharon Canan
no flags Details

Description Aharon Canan 2013-07-16 15:54:22 UTC
Description of problem:
can't create LSM snapshot

Version-Release number of selected component (if applicable):
3.3 is5

How reproducible:
100%

Steps to Reproduce:
1. on iscsi storage, start a vm with one disk on two hosts (my vm was running on the hsm)
2. live migrate the vms disk

Actual results:
failed to create snapshot

Expected results:
should work

Additional info:
================
Thread-4160::ERROR::2013-07-16 18:30:23,404::BindingXMLRPC::954::vds::(wrapper) unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/BindingXMLRPC.py", line 940, in wrapper
    res = f(*args, **kwargs)
TypeError: vmSnapshot() takes exactly 3 arguments (4 given)

Comment 1 Aharon Canan 2013-07-16 15:55:38 UTC
Created attachment 774392 [details]
libvirt

Comment 2 Aharon Canan 2013-07-16 15:57:45 UTC
Created attachment 774393 [details]
engine

Comment 3 Aharon Canan 2013-07-16 16:01:03 UTC
Created attachment 774395 [details]
spm

Comment 4 Aharon Canan 2013-07-16 16:03:17 UTC
Created attachment 774398 [details]
hsm

Comment 7 Arik 2013-07-17 08:12:01 UTC
Same as bz 983481 just in a different flow

Comment 8 Allon Mureinik 2013-07-21 11:54:45 UTC
Changing title - this bug has nothing to do with LSM's flow, it just appears there (too).

Comment 10 Allon Mureinik 2013-07-24 15:01:32 UTC
*** Bug 982289 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.