Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 984820 - "Unable to complete the requested operation due to: undefined method `exit_code' for #<ResultIO:0x00000006c52578>" will be shown after rhc threaddump a stopped gear
Summary: "Unable to complete the requested operation due to: undefined method `exit_co...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Michal Fojtik
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-16 06:26 UTC by Yan Du
Modified: 2015-05-14 23:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-29 12:48:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yan Du 2013-07-16 06:26:29 UTC
Description of problem:
create a ruby/jbossas-7 app and stop the app,  no warning infomation output after rhc threaddump a stopped gear


Version-Release number of selected component (if applicable):
STG(devenv-stage_406)
rhc-1.11.4


How reproducible:
Always


Steps to Reproduce:
1. create a ruby or jboss app
   rhc app create r18n ruby-1.8
2. visit app to make sure the app can be accessed in web
3. stop the app 
   rhc app stop r18n ruby-1.8
4. rhc threaddump r18n
   


Actual results:
no warning shown when rhc threaddump a stopped gear
[root@localhost ~]# rhc app stop r18n
RESULT:
r18n stopped
[root@localhost ~]# rhc threaddump r18n
[root@localhost ~]# 



Expected results:
should be show a warning when rhc threaddump a stopped gear, just like "Application is stopped, must be started to allow a thread dump"

Comment 1 Wei Sun 2013-07-29 07:29:09 UTC
Check this bug on INT(),it will show some error messages,like "Unable to complete the requested operation due to: undefined method `exit_code' for #<ResultIO:0x00000006c52578>."

[wsun@dhcp-8-229 ~]$ rhc threaddump r9
Unable to complete the requested operation due to: undefined method `exit_code' for #<ResultIO:0x00000006c52578>.
Reference ID: 5868c1a1035db776a28384a412c7e5c6

Comment 2 Michal Fojtik 2013-08-19 11:46:13 UTC
Tested on latest devenv, I'm getting:

→ rhc threaddump ruby01
Error occured while processing event 'thread-dump':Application is stopped, must be started to allow a thread dump

Then tested on INT:

→ OPENSHIFT_CONFIG=int rhc threaddump ruby02
Error occured while processing event 'thread-dump':Application is stopped, must be started to allow a thread dump

Not a bug?

Comment 3 Yan Du 2013-08-21 02:38:43 UTC
test on devenv_3680, it works now. could you pls. move to ON_QA side to verified it? Thanks.

root@openshift-ubuntu:~/test# rhc threaddump jboss7
Error occured while processing event 'thread-dump':Application is stopped, must be started to allow a thread dump

root@openshift-ubuntu:~/test# rhc  threaddump ruby18
Error occured while processing event 'thread-dump':Application is stopped, must be started to allow a thread dump

Comment 4 Yan Du 2013-08-21 10:36:13 UTC
according to #Comments 3, move the bug to verified.


Note You need to log in before you can comment on or make changes to this bug.