Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 984699 - [abrt] hplip-3.13.6-2.fc19: hpfax:55:bug:NameError: global name 'log' is not defined
Summary: [abrt] hplip-3.13.6-2.fc19: hpfax:55:bug:NameError: global name 'log' is not ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:68af8be5ebe9b17e38ceedc55ba...
: 1015977 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-15 17:46 UTC by Antonio Guzmán Simón
Modified: 2014-06-26 02:00 UTC (History)
5 users (show)

Fixed In Version: hplip-3.14.6-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-26 02:00:11 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2013-07-15 17:46 UTC, Antonio Guzmán Simón
no flags Details
File: core_backtrace (deleted)
2013-07-15 17:46 UTC, Antonio Guzmán Simón
no flags Details
File: environ (deleted)
2013-07-15 17:47 UTC, Antonio Guzmán Simón
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1201767 None None None Never

Description Antonio Guzmán Simón 2013-07-15 17:46:26 UTC
Version-Release number of selected component:
hplip-3.13.6-2.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/lib/cups/backend/hpfax
executable:     /usr/lib/cups/backend/hpfax
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
hpfax:55:bug:NameError: global name 'log' is not defined

Traceback (most recent call last):
  File "/usr/lib/cups/backend/hpfax", line 68, in <module>
    bug("Error setting home directory: /etc/hp/hplip.conf not found")
  File "/usr/lib/cups/backend/hpfax", line 55, in bug
    log.stderr("ERROR: %s\n" % msg)
NameError: global name 'log' is not defined

Local variables in innermost frame:
msg: 'Error setting home directory: /etc/hp/hplip.conf not found'

Comment 1 Antonio Guzmán Simón 2013-07-15 17:46:40 UTC
Created attachment 773853 [details]
File: backtrace

Comment 2 Antonio Guzmán Simón 2013-07-15 17:46:48 UTC
Created attachment 773854 [details]
File: core_backtrace

Comment 3 Antonio Guzmán Simón 2013-07-15 17:47:08 UTC
Created attachment 773855 [details]
File: environ

Comment 4 Jiri Popelka 2013-07-16 11:11:43 UTC
Antonio, your /etc/hp/hplip.conf file is missing.
Please reinstall hplip-common with this command:
# yum reinstall hplip-common
and try to reproduce the problem.

Comment 5 Jiri Popelka 2013-07-16 11:14:21 UTC
>   File "/usr/lib/cups/backend/hpfax", line 55, in bug
>     log.stderr("ERROR: %s\n" % msg)
> NameError: global name 'log' is not defined

Reported upstream as https://bugs.launchpad.net/bugs/1201767

Comment 6 Jiri Popelka 2013-10-07 08:55:25 UTC
*** Bug 1015977 has been marked as a duplicate of this bug. ***

Comment 7 Jonathan Nicol 2014-05-21 23:43:07 UTC
so I can't print anything thanks to a year-old bug. Ah well, maybe *2015* will be Year of Linux Desktop :(

Comment 8 Tim Waugh 2014-05-22 07:42:29 UTC
What does 'ls -l /etc/hp' say? If you're running into this I think it means a config file has gone missing.

Comment 9 Jiri Popelka 2014-05-22 09:29:00 UTC
(In reply to Jonathan Nicol from comment #7)
> so I can't print anything thanks to a year-old bug.

This bug causes that in some cases hplip is not able to write error message into log. This bug does not influence printing itself.

> Ah well, maybe *2015* will be Year of Linux Desktop :(

Might be if you're able to provide some info leading to identification of your problem.
https://fedoraproject.org/wiki/How_to_debug_printing_problems

Comment 10 Fedora Update System 2014-05-22 10:52:42 UTC
hplip-3.14.4-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2014-6291/hplip-3.14.4-5.fc20

Comment 11 Jonathan Nicol 2014-05-22 18:29:42 UTC
aha, the gnome printer config program installed hpijs and hplip-common for me; I had to manually install hplip. Now I can print :)

Comment 12 Jiri Popelka 2014-05-23 06:49:57 UTC
Thanks Jonathan,

your problem looks like bug #1094530.
We probably need to move something from hplip package into hplip-common, but I've no idea what.

It'd be great if you could remove the hplip again and try to print something via printing troubleshooter [1]. Attach the output into bug #1094530. Then you can install hplip back. Thanks.

[1] https://fedoraproject.org/wiki/How_to_debug_printing_problems#Printing_troubleshooter

Comment 13 Fedora Update System 2014-05-23 18:59:32 UTC
Package hplip-3.14.4-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.14.4-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6291/hplip-3.14.4-5.fc20
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2014-06-10 02:51:54 UTC
Package hplip-3.14.6-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.14.6-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6291/hplip-3.14.6-1.fc20
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2014-06-18 22:24:29 UTC
Package hplip-3.14.6-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hplip-3.14.6-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6291/hplip-3.14.6-2.fc20
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2014-06-26 02:00:11 UTC
hplip-3.14.6-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.