Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 984619 - [RFE] Enable loadbalancing vendors to implement their drivers
Summary: [RFE] Enable loadbalancing vendors to implement their drivers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 4.0
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: Upstream M3
: 4.0
Assignee: Ryan O'Hara
QA Contact: Rami Vaknin
URL: https://blueprints.launchpad.net/neut...
Whiteboard:
Depends On: 988923
Blocks: RHOS40RFE
TreeView+ depends on / blocked
 
Reported: 2013-07-15 14:43 UTC by Ryan O'Hara
Modified: 2016-04-26 19:20 UTC (History)
5 users (show)

Fixed In Version: openstack-neutron-2013.2-0.3.2.b3.el6ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-19 23:54:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-21 00:01:48 UTC

Description Ryan O'Hara 2013-07-15 14:43:55 UTC
The design goal is to continue what was outlined during Grizzly, which is to have a single LBaaS plugin running multi-vendor drivers selected via the Service Type semantics. This blueprint is focused on defining the steps needed to add “Driver” support for Havana.

https://blueprints.launchpad.net/neutron/+spec/multi-vendor-support-for-lbaas

Comment 2 Ryan O'Hara 2013-09-17 17:21:20 UTC
This feature has been completed upstream.

Comment 7 Rami Vaknin 2013-12-05 09:13:26 UTC
Verified.
I was able to use various service_type(s) in the service_provider, and no regressions observed.

Tested on rhos 4.0 on rhel 6.5, puddle 2013-11-26.3,
openstack-neutron-2013.2-10.el6ost.noarch

Comment 10 errata-xmlrpc 2013-12-19 23:54:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html


Note You need to log in before you can comment on or make changes to this bug.