Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 984309 - LUKSError: luks device not configured
Summary: LUKSError: luks device not configured
Keywords:
Status: CLOSED DUPLICATE of bug 983099
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e69fcae66d283be0815bfc719c1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-14 18:04 UTC by Charles R. Anderson
Modified: 2013-08-08 13:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-08 13:48:31 UTC


Attachments (Terms of Use)
File: anaconda.log (deleted)
2013-07-14 18:04 UTC, Charles R. Anderson
no flags Details
File: environ (deleted)
2013-07-14 18:04 UTC, Charles R. Anderson
no flags Details
File: lsblk_output (deleted)
2013-07-14 18:05 UTC, Charles R. Anderson
no flags Details
File: messages (deleted)
2013-07-14 18:05 UTC, Charles R. Anderson
no flags Details
File: nmcli_dev_list (deleted)
2013-07-14 18:05 UTC, Charles R. Anderson
no flags Details
File: os_info (deleted)
2013-07-14 18:05 UTC, Charles R. Anderson
no flags Details
File: program.log (deleted)
2013-07-14 18:05 UTC, Charles R. Anderson
no flags Details
File: ifcfg.log (deleted)
2013-07-14 18:05 UTC, Charles R. Anderson
no flags Details
File: anaconda-tb (deleted)
2013-07-14 18:06 UTC, Charles R. Anderson
no flags Details
File: storage.log (deleted)
2013-07-14 18:06 UTC, Charles R. Anderson
no flags Details

Description Charles R. Anderson 2013-07-14 18:04:32 UTC
Description of problem:
Went through custom partitioning, rescanning the disks several times to start over because it didn't find all the LVM LVs after unlocking the encrypted PV.  After the third or fourth rescan, it found the LVs but didn't detect the Fedora installations on them.  Deleted one LV, created a new LV as /, and reformatted a partition as /boot.  Clicked done.  Started the installation process. While it was formatting, entered the root password.  Then this crash happened.

Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/luks.py", line 163, in setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 840, in setupParents
    _format.setup()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 703, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 832, in setupParents
    parent.setup(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 703, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2222, in _preSetup
    return StorageDevice._preSetup(self, orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 309, in setupParents
    parent.setup(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 2623, in setupParents
    Device.setupParents(self, orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 703, in _preSetup
    self.setupParents(orig=orig)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 714, in setup
    if not self._preSetup(orig=orig):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 526, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 140, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
LUKSError: luks device not configured

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-blivet-0.17-1.fc19.noarch, python-libs-2.7.5-1.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Comment 1 Charles R. Anderson 2013-07-14 18:04:51 UTC
Created attachment 773387 [details]
File: anaconda.log

Comment 2 Charles R. Anderson 2013-07-14 18:04:55 UTC
Created attachment 773388 [details]
File: environ

Comment 3 Charles R. Anderson 2013-07-14 18:05:01 UTC
Created attachment 773389 [details]
File: lsblk_output

Comment 4 Charles R. Anderson 2013-07-14 18:05:06 UTC
Created attachment 773390 [details]
File: messages

Comment 5 Charles R. Anderson 2013-07-14 18:05:15 UTC
Created attachment 773391 [details]
File: nmcli_dev_list

Comment 6 Charles R. Anderson 2013-07-14 18:05:19 UTC
Created attachment 773392 [details]
File: os_info

Comment 7 Charles R. Anderson 2013-07-14 18:05:22 UTC
Created attachment 773393 [details]
File: program.log

Comment 8 Charles R. Anderson 2013-07-14 18:05:26 UTC
Created attachment 773394 [details]
File: ifcfg.log

Comment 9 Charles R. Anderson 2013-07-14 18:06:05 UTC
Created attachment 773395 [details]
File: anaconda-tb

Comment 10 Charles R. Anderson 2013-07-14 18:06:13 UTC
Created attachment 773397 [details]
File: storage.log

Comment 11 David Shea 2013-08-08 13:48:31 UTC

*** This bug has been marked as a duplicate of bug 983099 ***


Note You need to log in before you can comment on or make changes to this bug.