Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 984233 - Task form (Work) popup window is missing link to Assignment popup
Summary: Task form (Work) popup window is missing link to Assignment popup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ER2
: 6.0.0
Assignee: Mauricio Salatino
QA Contact: Jan Hrcek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-13 20:12 UTC by Jan Hrcek
Modified: 2014-08-06 20:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:10:45 UTC
Type: Bug


Attachments (Terms of Use)
Link to Assignments missing in the Work (Task form) popup (deleted)
2013-07-13 20:12 UTC, Jan Hrcek
no flags Details

Description Jan Hrcek 2013-07-13 20:12:48 UTC
Created attachment 773169 [details]
Link to Assignments missing in the Work  (Task form) popup

Description of problem:
Task form - One of the task-related popups in the Task List - does not contain link to Assignments popup (see screenshot attached)

Version-Release number of selected component (if applicable):
6.0.0.DR6

How reproducible:
Always

Steps to Reproduce:
1. Go to Tasks > Tasks List
2. Create a task using New Task
3. Click on Work icon for the new task

Actual results:
The resulting popup does not contain link to Assignment popup (unlike the other 3 popups -Task details, Task assignments and Task comments - that do contain that link).

Expected results:
The link should be present as marked in the screenshot to make the gui consistent.

Additional info:
The problem is in 
org.jbpm.console.ng.ht.client.editors.taskform.FormDisplayPopupPresenter
> method renderTaskForm, which does not add NavLink pointing to the assignment popup.

Comment 1 Mauricio Salatino 2013-07-15 10:14:03 UTC
Fixed in master:
http://github.com/droolsjbpm/jbpm-console-ng/commit/4edd06d0c

Comment 2 Jan Hrcek 2013-09-04 06:43:26 UTC
Verified with BPMS 6.0.0.ER2


Note You need to log in before you can comment on or make changes to this bug.