Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 983831 - blockdev-snapshot-sync error info not correct when snapshot-file format is raw
Summary: blockdev-snapshot-sync error info not correct when snapshot-file format is raw
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jeff Cody
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-12 03:39 UTC by ShupingCui
Modified: 2016-05-16 04:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-06 18:33:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description ShupingCui 2013-07-12 03:39:53 UTC
Description of problem:
blockdev-snapshot-sync error info not correct when snapshot-file format is raw

Version-Release number of selected component (if applicable):
Host:
kernel-3.10.0-0.rc7.64.el7.x86_64
qemu-kvm-1.5.1-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot the guest
/usr/libexec/qemu-kvm \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -drive file='/root/tests/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/RHEL-Server-6.5-64-virtio.raw',if=none,id=drive-virtio-disk1,media=disk,cache=none,snapshot=off,format=raw,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \
    -device virtio-net-pci,netdev=idzO9nto,mac='9a:ad:ae:af:b0:b1',bus=pci.0,addr=0x3,id='idcPlNMt' \
    -netdev tap,id=idzO9nto,vhost=on,fd=22 \
    -m 8192 \
    -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 \
    -cpu 'Nehalem' \
    -M pc \
    -vnc :0 \
    -vga cirrus \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off   \
    -no-kvm-pit-reinjection \
    -enable-kvm \
    -qmp tcp:0:6666,server,nowait \
    -monitor stdio
2. run blockdev-snapshot-sync
{"execute": "blockdev-snapshot-sync", "arguments": {"device": "drive-virtio-disk1", "snapshot-file": "/root/tests/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/RHEL-Server-6.5-64-virtio-snapshot.raw", "format": "raw"}, "id": "DHz0KJFp"}
3.

Actual results:
{"id": "DHz0KJFp", "error": {"class": "GenericError", "desc": "Backing file not supported for file format 'raw'"}}

Expected results:
{"id": "DHz0KJFp", "error": {"class": "GenericError", "desc": "Snapshot file not supported for file format 'raw'"}}

Additional info:

Comment 2 Jeff Cody 2013-09-06 18:33:36 UTC
That is the correct error.  The format type "raw" does not support backing files.  When the snapshot command attempts to create a new image, of type "raw", that necessitates the snapshot having a backing format.  Since "raw" does not support backing formats, you will get the error "Backing file not supported for file format 'raw'". You cannot create the snapshot since 'raw' does not support backing files.


Note You need to log in before you can comment on or make changes to this bug.