Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 983762 - synergy: /builddir/build/BUILD/synergy-1.4.10-Source/src/lib/synergy/CClientApp.cpp,163
Summary: synergy: /builddir/build/BUILD/synergy-1.4.10-Source/src/lib/synergy/CClientA...
Alias: None
Product: Fedora
Classification: Fedora
Component: synergy
Version: 20
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2013-07-11 22:27 UTC by Douglas Schilling Landgraf
Modified: 2015-06-29 12:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2015-06-29 12:04:34 UTC

Attachments (Terms of Use)

Description Douglas Schilling Landgraf 2013-07-11 22:27:33 UTC
Description of problem:

$ synergyc --daemon --restart -n blue.domain.local red.domain.local
2013-07-11T19:23:15 INFO: Synergy 1.4.10 Client on Linux 3.9.4-301.fc19.x86_64 #1 SMP Tue Jun 4 00:30:04 UTC 2013 x86_64

$ ps aux | grep -i synergyc
douglas  14636  0.0  0.0 112644   924 pts/5    S+   19:23   0:00 grep --color=auto -i synergyc

Version-Release number of selected component (if applicable):


How reproducible:

1) Install synergy
2) Try to run above command.

Actual results:

synergy daemon is not initialized.

Expected results:

synergy daemon be initialized.

Additional info:

synergy-1.3.7-7.fc19.x86_64.rpm works.

Comment 1 Marcelo Moreira de Mello 2013-07-11 23:51:26 UTC
Hello Douglas, 

  It's working to me. Look below:

~ $ rpm -q synergy

~ $ ps aux | grep synergy
mdemello  2425  0.1  0.0 129392  3448 ?        Ssl  Jul08   6:13 synergys -a --daemon -n theo.mmello.local -c /home/mdemello/.synergy.conf

#conf file on the server
~ $ cat .synergy.conf 
section: screens

section: links
        left = t530.mmello.local
        up = sophie.mmello.local
        right = theo.mmello.local
        down  = theo.mmello.local

section: options
    heartbeat = 500
    screenSaverSync = true

t530> rpm -q synergy

t530> ps aux | grep syner
mdemello  3689  0.4  0.0 130832  2904 ?        Ssl  11:00   2:56 synergyc --name t530.mmello.local theo.mmello.local

conf file on the client
t530> cat .synergy.conf 
section: screens

section: links
        right = theo.mmello.local
        down  = theo.mmello.local
        left = t530.mmello.local
        up = sophie.mmello.local

section: options
    heartbeat = 500 
    screenSaverSync = true

Comment 2 Marcelo Moreira de Mello 2013-07-11 23:52:59 UTC

~ $ synergys --daemon --restart -a --daemon -n theo.mmello.local -c /home/mdemello/.synergy.conf
2013-07-11T20:52:31 INFO: Synergy 1.4.10 Server on Linux 3.9.8-300.fc19.x86_64 #1 SMP Thu Jun 27 19:24:23 UTC 2013 x86_64
2013-07-11T20:52:31 DEBUG: opening configuration "/home/mdemello/.synergy.conf"
2013-07-11T20:52:31 DEBUG: configuration read successfully
~ $ ps aux | grep syner
mdemello 13027  0.2  0.0 128584  2540 ?        Ssl  20:52   0:00 synergys --daemon --restart -a --daemon -n theo.mmello.local -c /home/mdemello/.synergy.conf
mdemello 13071  0.0  0.0 112656   920 pts/0    S+   20:52   0:00 grep --color=auto syner

Comment 3 John Poelstra 2014-02-20 03:58:22 UTC
I have the same problem as the original reporter.  I'm trying to connect a Fedora 19 client to a Ubuntu 12.04 server.

I tried installing the latest upstream rpm and it did not fix my problem.

Any suggested workarounds would be greatly appreciated.

Comment 4 John Poelstra 2014-02-20 22:43:38 UTC
Bumping version to "20" as I can reproduce it there too with the same error message.

Correction my previous comment... I was NOT able to try the upstream version because of a failed ssl dependency.  Sorry for putting that in the comments.. I mixed them up with other OS I was trying.  From a Mac I was able to connect to the same Ubuntu Synergy server.

Comment 5 Fedora End Of Life 2015-05-29 09:10:35 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Fedora End Of Life 2015-06-29 12:04:34 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.