Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 983431 - DHT: NFS process crashed on a node in a cluster when another storage node in the cluster went offline
Summary: DHT: NFS process crashed on a node in a cluster when another storage node in ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Nagaprasad Sathyanarayana
QA Contact:
URL:
Whiteboard:
Depends On: 982181
Blocks: 1139996
TreeView+ depends on / blocked
 
Reported: 2013-07-11 08:19 UTC by shishir gowda
Modified: 2016-02-18 00:19 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 982181
: 1139996 (view as bug list)
Environment:
Last Closed: 2014-04-17 11:43:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2013-07-11 08:29:46 UTC
REVIEW: http://review.gluster.org/5319 (cluster/dht: Prevent dht_access from going into a loop.) posted (#1) for review on master by Shishir Gowda (sgowda@redhat.com)

Comment 2 Anand Avati 2013-07-12 06:10:51 UTC
REVIEW: http://review.gluster.org/5319 (cluster/dht: Prevent dht_access from going into a loop.) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)

Comment 3 Anand Avati 2013-07-12 09:18:34 UTC
REVIEW: http://review.gluster.org/5319 (cluster/dht: Prevent dht_access from going into a loop.) posted (#3) for review on master by Shishir Gowda (sgowda@redhat.com)

Comment 4 Anand Avati 2013-07-16 06:57:14 UTC
COMMIT: http://review.gluster.org/5319 committed in master by Anand Avati (avati@redhat.com) 
------
commit 3e1d8e1689c47d8b83343a403e7d09c018472155
Author: shishir gowda <sgowda@redhat.com>
Date:   Thu Jul 11 13:44:51 2013 +0530

    cluster/dht: Prevent dht_access from going into a loop.
    
    If access fails with ENOTCONN, do not wind to same subvol.
    We wind to first-up-subvol if access fails with ENOTCONN.
    In few cases, if dht has only 1 subvolume, and access fails with
    ENOTCONN, we go into a infinite loop of winding to same subvol
    
    The fix is to check if we previously wound to same subvol, and
    fail if first-up-subvol is same.
    
    Change-Id: Ib5d3ce7d33e8ea09147905a7df1ed280874fa549
    BUG: 983431
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5319
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>

Comment 7 Niels de Vos 2014-04-17 11:43:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.