Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 983032 - Moving hosts to maintenance and updating libvirt causes host to get stuck on "unassigned" status
Summary: Moving hosts to maintenance and updating libvirt causes host to get stuck on ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.3.0
Assignee: Yaniv Bronhaim
QA Contact:
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-10 10:40 UTC by Ohad Basan
Modified: 2016-02-10 19:02 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-06 12:49:39 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
activate host after upgrading libvirt version (deleted)
2013-08-06 10:57 UTC, Yaniv Bronhaim
no flags Details
activate host after upgrading libvirt version (deleted)
2013-08-06 10:58 UTC, Yaniv Bronhaim
no flags Details

Description Ohad Basan 2013-07-10 10:40:27 UTC
Description of problem:
when trying to yum update libvirt when the hosts are in maintenance.
after trying to activate them they get stuck in "unassigned" status
I can't remove, reinstall them or perform any other operation to free them



Steps to Reproduce:
1.install a host on rhev is5.
2.move host to maintenance.
3.run yum update libvirt on the host
4. activate host from the ui

Actual results:
host gets stuck on unassigned

Expected results:

host should become active

Comment 1 Ohad Basan 2013-07-10 10:44:29 UTC
imho, if it's impossible to update a libvirt's host.
at least the "reinstall host" option should be provided.

Comment 4 Ohad Basan 2013-07-10 10:58:54 UTC
restarting vdsm service on the host fixed the problem and the hosts are activate again

Comment 5 Barak 2013-07-10 21:13:31 UTC
From which  version to which version was libvirt updated?
Usually when manually yum updating a service (libvirt in this case) one must restart the version manually otherwise changes might not take place , was this performed in this case?

Comment 6 Ohad Basan 2013-07-11 08:42:37 UTC
I updated it from version  libvirt-0.10.2-18.el6_4.9.x86_64
from libvirt-0.10.2-18.el6_4.8.x86_64

I did not restart the libvirtd after updating.
maybe this was the problem

Comment 7 Barak 2013-07-25 12:28:51 UTC
Yaniv,

Please check whether:
- move host to maintenance
- yum update libvirt
- restart libvirt

It it works fine than this bug needs to move to CLOSE NOPTABUG

Comment 8 Yaniv Bronhaim 2013-08-06 10:57:14 UTC
Created attachment 783268 [details]
activate host after upgrading libvirt version

Comment 9 Yaniv Bronhaim 2013-08-06 10:58:48 UTC
Created attachment 783269 [details]
activate host after upgrading libvirt version

Comment 10 Yaniv Bronhaim 2013-08-06 10:59:32 UTC
Did deploy with libvirt-0.10.2-18.el6_4.8.x86_64, put on maintenance, upgrade to libvirt-0.10.2-18.el6_4.9.x86_64 and activate. All worked as expected.
                                                                                
Attaching yum.log and engine.log                                                
The reason for unassigned stuck status wasn't the upgrade

Comment 11 Yaniv Bronhaim 2013-08-06 11:13:51 UTC
is it duplicated of Bug 991729 ?

Comment 12 Barak 2013-08-06 12:49:39 UTC
per comment #10 moving to CLOSED NOTABUG


Note You need to log in before you can comment on or make changes to this bug.