Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 982881 - dhcpd: systemd unit file ignores interface list
Summary: dhcpd: systemd unit file ignores interface list
Keywords:
Status: CLOSED DUPLICATE of bug 909733
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jiri Popelka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-10 05:04 UTC by H. Peter Anvin
Modified: 2013-07-10 06:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-10 06:43:41 UTC


Attachments (Terms of Use)

Description H. Peter Anvin 2013-07-10 05:04:08 UTC
Description of problem:
To run dhcpd on a restricted set of interfaces, the list of interfaces has to be specified on the command line.  This list of interfaces has in the past been located in /etc/sysconfig/dhcpd, but in Fedora 19 this file is completely ignored by the systemd unit file.

***This information cannot be provided in dhcpd.conf***

Version-Release number of selected component (if applicable):
dhcp-4.2.5-15.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Try to run dhcpd on a subset of interfaces, perhaps because you have another process wanting to use the DHCP ports on the balance of interfaces
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Tomáš Hozza 🤓 2013-07-10 06:43:41 UTC
We dropped using EnvironmentFile in dhcpd.service file in Fedora 18. If you need
to use custom dhcpd.service file you should copy the whole service file from
/lib/systemd/system to /etc/systemd/system and edit it there. Service files in
/etc/systemd/system have higher precedence over service files in
/lib/systemd/system.

For more information please see:
http://fedoraproject.org/wiki/Systemd#How_do_I_customize_a_unit_file.2F_add_a_custom_unit_file.3F

*** This bug has been marked as a duplicate of bug 909733 ***


Note You need to log in before you can comment on or make changes to this bug.