Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 982788 - gnome-rdp Unhandled Exception startup failure after upgrade
Summary: gnome-rdp Unhandled Exception startup failure after upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-rdp
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Luis Bazan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-09 21:57 UTC by Brian Dudek
Modified: 2013-11-12 00:38 UTC (History)
6 users (show)

Fixed In Version: gnome-rdp-0.3.1.0-7.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-12 00:38:07 UTC


Attachments (Terms of Use)

Description Brian Dudek 2013-07-09 21:57:02 UTC
Description of problem:
After update of gnome-rdp startup failure and terminal messages:

[dudek@blackf19 ~]$ gnome-rdp

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for AppIndicator.ApplicationIndicator ---> System.DllNotFoundException: libappindicator.so.1
  at (wrapper managed-to-native) AppIndicator.ApplicationIndicator:app_indicator_get_type ()
  at AppIndicator.ApplicationIndicator.get_GType () [0x00000] in <filename unknown>:0 
  at GtkSharp.AppindicatorSharp.ObjectManager.Initialize () [0x00000] in <filename unknown>:0 
  at AppIndicator.ApplicationIndicator..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at GnomeRDP.MainWindow..ctor () [0x00000] in <filename unknown>:0 
  at GnomeRDP.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for AppIndicator.ApplicationIndicator ---> System.DllNotFoundException: libappindicator.so.1
  at (wrapper managed-to-native) AppIndicator.ApplicationIndicator:app_indicator_get_type ()
  at AppIndicator.ApplicationIndicator.get_GType () [0x00000] in <filename unknown>:0 
  at GtkSharp.AppindicatorSharp.ObjectManager.Initialize () [0x00000] in <filename unknown>:0 
  at AppIndicator.ApplicationIndicator..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at GnomeRDP.MainWindow..ctor () [0x00000] in <filename unknown>:0 
  at GnomeRDP.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 



Version-Release number of selected component (if applicable):

[root@blackf19 ~]$ cat /etc/redhat-release 
Fedora release 19 (Schrödinger’s Cat)

[root@blackf19 log]# rpm -q gnome-shell gnome-rdp gdm ; uname -r
gnome-shell-3.8.3-3.fc19.x86_64
gnome-rdp-0.2.3-10.fc17.x86_64
gdm-3.8.3-2.fc19.x86_64
3.9.9-301.fc19.x86_64



Steps to Reproduce:

[root@blackf19 log]# rpm -q gnome-rdp
gnome-rdp-0.2.3-10.fc17.x86_64

[root@blackf19 log]# yum -y update gnome-rdp

[root@blackf19 log]# rpm -q gnome-rdp
gnome-rdp-0.3.1.0-5.fc20.x86_64

[dudek@blackf19 ~]# gnome-rdp
launch errors included above.......

Downgrade to correct the problem.

[root@blackf19 log]# yum -y downgrade gnome-rdp

[root@blackf19 log]# rpm -q gnome-rdp
gnome-rdp-0.2.3-10.fc17.x86_64


After downgrade gnome-rdp launches as expected as before the upgrade.

Comment 1 Brian Dudek 2013-07-09 22:51:30 UTC
[root@blackf19 ~]# rpm -q libappindicator-sharp
libappindicator-sharp-12.10.0-2.fc19.x86_64

libappindicator-sharp is a dependency of the new gnome-rdp-0.3.1 - this may be the issue?

libappindicator-sharp was not required for the old gnome-rdp-0.2.3

Comment 2 Brian Dudek 2013-07-09 22:58:03 UTC
I think the issue is a missing dependency.  Yum install libappindicator and its dependencies, now gnome-rdp works as expected.

This set-up works as expected:


[root@blackf19 ~]# rpm -q gnome-rdp libappindicator libappindicator-sharp libdbusmenu libdbusmenu-gtk2 libindicator
gnome-rdp-0.3.1.0-5.fc19.x86_64
libappindicator-12.10.0-2.fc19.x86_64
libappindicator-sharp-12.10.0-2.fc19.x86_64
libdbusmenu-12.10.2-3.fc19.x86_64
libdbusmenu-gtk2-12.10.2-3.fc19.x86_64
libindicator-12.10.1-1.fc19.x86_64

Comment 3 Eduardo Echeverria 2013-07-09 23:05:38 UTC
really, is a missing dependency, libappindicator, I will push an update ASAP

Comment 4 Gianluca Cecchi 2013-09-13 08:07:12 UTC
hello,
just installed today gnome-rdp on an updated f19 and the problem seems not resolved.

yum install gnome-rdp 
took inside these packages
Sep 13 09:59:16 Installed: tigervnc-license-1.3.0-3.fc19.noarch
Sep 13 09:59:16 Installed: tigervnc-server-minimal-1.3.0-3.fc19.x86_64
Sep 13 09:59:16 Installed: tigervnc-server-1.3.0-3.fc19.x86_64
Sep 13 09:59:16 Installed: libgdiplus-2.10-9.fc19.x86_64
Sep 13 09:59:18 Installed: mono-core-2.10.8-4.fc19.x86_64
Sep 13 09:59:18 Installed: gtk-sharp2-2.12.11-7.fc19.x86_64
Sep 13 09:59:18 Installed: libappindicator-sharp-12.10.0-2.fc19.x86_64
Sep 13 09:59:18 Installed: gnome-keyring-sharp-1.0.1-0.12.133722svn.fc19.x86_64
Sep 13 09:59:18 Installed: mono-data-sqlite-2.10.8-4.fc19.x86_64
Sep 13 09:59:19 Installed: tigervnc-icons-1.3.0-3.fc19.noarch
Sep 13 09:59:20 Installed: tigervnc-1.3.0-3.fc19.x86_64
Sep 13 09:59:20 Installed: gnome-rdp-0.3.1.0-5.fc19.x86_64

and starting gnome-rdp gave:

[g.cecchi@ope46 ~]$ gnome-rdp 

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for AppIndicator.ApplicationIndicator ---> System.DllNotFoundException: libappindicator.so.1
  at (wrapper managed-to-native) AppIndicator.ApplicationIndicator:app_indicator_get_type ()
  at AppIndicator.ApplicationIndicator.get_GType () [0x00000] in <filename unknown>:0 
  at GtkSharp.AppindicatorSharp.ObjectManager.Initialize () [0x00000] in <filename unknown>:0 
  at AppIndicator.ApplicationIndicator..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at GnomeRDP.MainWindow..ctor () [0x00000] in <filename unknown>:0 
  at GnomeRDP.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for AppIndicator.ApplicationIndicator ---> System.DllNotFoundException: libappindicator.so.1
  at (wrapper managed-to-native) AppIndicator.ApplicationIndicator:app_indicator_get_type ()
  at AppIndicator.ApplicationIndicator.get_GType () [0x00000] in <filename unknown>:0 
  at GtkSharp.AppindicatorSharp.ObjectManager.Initialize () [0x00000] in <filename unknown>:0 
  at AppIndicator.ApplicationIndicator..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at GnomeRDP.MainWindow..ctor () [0x00000] in <filename unknown>:0 
  at GnomeRDP.Program.Main (System.String[] args) [0x00000] in <filename unknown>:0 


then

yum install libappindicator

gave
Sep 13 10:05:41 Installed: libdbusmenu-12.10.2-3.fc19.x86_64
Sep 13 10:05:41 Installed: libdbusmenu-gtk2-12.10.2-3.fc19.x86_64
Sep 13 10:05:41 Installed: libindicator-12.10.1-1.fc19.x86_64
Sep 13 10:05:41 Installed: libappindicator-12.10.0-2.fc19.x86_64

and gnome-rdp works.

only got these warnings:
(gnome-rdp:2887): GLib-GObject-WARNING **: gsignal.c:2475: signal `child-added' is invalid for instance `0x25ab370' of type `GtkMenu'

(gnome-rdp:2887): GLib-GObject-WARNING **: gsignal.c:2475: signal `child-added' is invalid for instance `0x25ab510' of type `GtkMenu'


Can you please update dependency tree?

Thanks,
Gianluca

Comment 5 Fedora Update System 2013-09-13 11:31:28 UTC
gnome-rdp-0.3.1.0-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-rdp-0.3.1.0-7.fc19

Comment 6 Fedora Update System 2013-09-14 02:37:48 UTC
Package gnome-rdp-0.3.1.0-7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-rdp-0.3.1.0-7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16701/gnome-rdp-0.3.1.0-7.fc19
then log in and leave karma (feedback).

Comment 7 Charles Butterfield 2013-09-14 14:12:01 UTC
The above item in F19 testing (comment #6) works for me.  Thanks!

Comment 8 Fedora Update System 2013-09-24 00:28:45 UTC
gnome-rdp-0.3.1.0-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-11-06 21:03:33 UTC
gnome-rdp-0.3.1.0-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-rdp-0.3.1.0-7.fc20

Comment 10 Fedora Update System 2013-11-07 19:07:19 UTC
Package gnome-rdp-0.3.1.0-7.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-rdp-0.3.1.0-7.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20859/gnome-rdp-0.3.1.0-7.fc20
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-11-12 00:38:07 UTC
gnome-rdp-0.3.1.0-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.