Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 982757 - RMDA Volumes Silently Revert to TCP
Summary: RMDA Volumes Silently Revert to TCP
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rdma
Version: 3.4.0-beta
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: GlusterFS Bugs list
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-09 19:34 UTC by Ryan
Modified: 2014-10-14 13:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 13:14:40 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ryan 2013-07-09 19:34:42 UTC
Description of problem: RDMA Silently Reverts to TCP if there is a client issue/nonfunctioning RDMA subsystem


Version-Release number of selected component (if applicable): 3.4.beta4


How reproducible: Reliably


Steps to Reproduce:
1. Create an RDMA/TCP Volume
2. Unload the Kernel Module RDMA_CM on the client (if loaded)
3. Mount the volume via RDMA on the client

Actual results:

The volume will mount, report as RDMA mount, however TCP will be used as the transport mechanism.


Expected results:

The volume mount should either fail outright (since RDMA was explicitly defined) or revert to TCP with a warning message. 


Additional info:

Comment 1 Matt Nicholson 2013-07-10 19:08:16 UTC
Seeing this in out test 3.4beat4 setup, volumes with transport=tcp,rdma, when mounted explicitly with Rmda silently fail to tcp. A warning message @ mount time would be nice, or perhaps a mount option to prevent failover to tcp when specified.

Comment 2 Kaleb KEITHLEY 2014-10-14 13:14:40 UTC
RDMA on IB works in 3.5. Please upgrade to a current 3.5 release if you need RDMA.


Note You need to log in before you can comment on or make changes to this bug.