Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 982615 - when creating a scalable app I get HAProxy reported with severity "result"
Summary: when creating a scalable app I get HAProxy reported with severity "result"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Mrunal Patel
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-09 12:14 UTC by Andre Dietisheim
Modified: 2015-05-14 23:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-07 22:54:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker JBIDE-15158 Major Open if I create a scalable application I get a non-useful dialog about HAProxy (watcher) 2013-08-08 08:11:00 UTC

Description Andre Dietisheim 2013-07-09 12:14:04 UTC
Description of problem:
If I create a scalable application I get a result of HAProxy being started with severity "result". This rather strange/not consistent since the appliation itself is reported via severity "info". 

[
    {
        "exit_code" => big integer 0,
        "field" => undefined,
        "severity" => "info",
        "text" => "Application scalable was created."
    },
    {
        "exit_code" => big integer 0,
        "field" => undefined,
        "severity" => "debug",
        "text" => "The cartridge jbossas deployed a template application"
    },
    {
        "exit_code" => big integer 0,
        "field" => undefined,
        "severity" => "result",
        "text" => "HAProxy instance is started
"
    }
]

Furthermore the basic logic we were told to follow is to show the user whatever is reported as "field": "result" or "severity":"result". Thus if a user of the Eclipse tooling is creating a scalable applicaiton he'll get a dialog about HAProxy being started which is weird usabilitywise.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a scalable application
2.
3.

Actual results:


Expected results:
HAProxy being started should get reported with severity "info" or "debug"

Additional info:

Comment 1 Lili Nader 2013-07-09 19:27:11 UTC
This might be a duplicate of bug 980928
	

https://bugzilla.redhat.com/show_bug.cgi?id=980928

Comment 2 Lili Nader 2013-07-10 09:04:11 UTC

*** This bug has been marked as a duplicate of bug 980928 ***

Comment 3 Andre Dietisheim 2013-07-10 13:56:58 UTC
Is duplicate with https://bugzilla.redhat.com/show_bug.cgi?id=980928 in terms of code? To me as a user this doesn't look duplicate, the issue here is a "bad" severity ("result" where it should be "info") and not a compatibility issue like #980928

Comment 4 Andre Dietisheim 2013-07-17 13:51:36 UTC
This was closed as duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=980928. On INT, where I see https://bugzilla.redhat.com/show_bug.cgi?id=980928 fixed since I get messages with field "result", I still experience this. 

I thus reopen this issue an ask you to please clarify:

* If this is expected: please re-close as "NOT A BUG"
* If this is not expected: please keep this opened until the message severity/field is changed to "info".

Comment 5 Lili Nader 2013-07-25 22:11:39 UTC
Sorry Andre I misunderstood your comments.  

The broker sets the messages returned from node as CLIENT_RESULT to severity=result.  I agree with you that this message "HAProxy instance is started" should be debug.  

This fix needs to happen in HAProxy cartridge.  I'm assigning the bug to node/runtime team for a fix.

Comment 6 Mrunal Patel 2013-07-29 19:20:38 UTC
https://github.com/openshift/origin-server/pull/3207

Have changed code to use client_message instead of client_result.

Comment 7 Meng Bo 2013-07-30 06:26:31 UTC
Checked on devenv_3580, the message severity level show warning this time.

    "messages": [
        {
            "exit_code": 0, 
            "field": null, 
            "severity": "info", 
            "text": "Application app3s was created."
        }, 
        {
            "exit_code": 0, 
            "field": null, 
            "severity": "warning", 
            "text": "HAProxy instance is started\n"


@Andre Dietisheim  
Not sure if the current result is acceptable. Can you please help move the bug to verified if it is ok.

Comment 8 Meng Bo 2013-07-30 06:28:51 UTC
According commnet#4, assign the bug back.

Comment 9 Andre Dietisheim 2013-07-30 12:00:04 UTC
@Meng Bo: As soon as severity/field are not RESULT we wont show it in the Eclipse tooling which is what a user is imho expecting. We have a generic logic in the tooling where we only show messages that are either RESULT in severity or in field.
I cant say if DEBUG or WARNING are the right severities for you guys though.

Comment 10 Meng Bo 2013-07-30 12:07:37 UTC
According to comment#9, please move the bug back to ON_QA, and QE will verify it.

Comment 11 Andre Dietisheim 2013-07-30 12:26:17 UTC
@Meng Bo:
I apparently cannot set this status (ON_QA). The only choices I have in status are assigned or closed. What do I miss?

Comment 12 Xiaoli Tian 2013-07-30 14:29:57 UTC
Move it back to ON_QA according to comment 7 and comment 9

Comment 13 Meng Bo 2013-07-31 09:19:56 UTC
Move bug to verified.


Note You need to log in before you can comment on or make changes to this bug.