Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 982547 - After deployed a localcandlepin, register from client failed
Summary: After deployed a localcandlepin, register from client failed
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 0.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: candlepin-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-09 09:27 UTC by xingge
Modified: 2016-09-20 02:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-29 02:40:21 UTC


Attachments (Terms of Use)
rhsm.log when error happens (deleted)
2013-07-09 09:27 UTC, xingge
no flags Details
localcandlepin deploy script (deleted)
2013-07-09 09:28 UTC, xingge
no flags Details

Description xingge 2013-07-09 09:27:12 UTC
Created attachment 770870 [details]
rhsm.log when error happens

Description of problem:
After deployed a localcandlepin, register from client failed

Version-Release number of selected component (if applicable):
Server: localcandlepin source code download form git hub.
Client: RHEL5.10

How reproducible:
always

Steps to Reproduce:
1.deploy the localcandlepin with the attached shell script

2.cp localcandlepin cert and change rhsm.conf at the rhel5.10
scp localcandlepin.redhat.com:/etc/candlepin/certs/candlepin-ca.crt /etc/rhsm/ca/candlepin-local.pem
subscription-manager config --server.hostname=localcandlepin.redhat.com --server.prefix='/candlepin' --server.port=8443 --rhsm.repo_ca_cert='/etc/rhsm/ca/candlepin-local.pem'

3.register the system
subscritpion-manager register --username=testuser2 --password=password

Actual results:
the output is :
certificate verify failed
or:
No such consumer type: system

Expected results:
the system should registered successfully

Additional info:

Comment 1 xingge 2013-07-09 09:28:17 UTC
Created attachment 770872 [details]
localcandlepin deploy script

Comment 2 Amanda Carter 2013-07-26 17:53:36 UTC
This isn't an IT issue, so moving to the proper place. That said, this is likely a config issue and not a bug that you can resolve by mailing entitlement-team-list instead.

Comment 3 xingge 2013-07-29 02:44:09 UTC
After deploy a new local candlepin the issue disappeared, so close this bug.


Note You need to log in before you can comment on or make changes to this bug.