Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 982365 - Subscriptions nutupane does not work as intended
Summary: Subscriptions nutupane does not work as intended
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello
Version: 1.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Katello Bug Bin
QA Contact: sthirugn@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: sam20-tracker
TreeView+ depends on / blocked
 
Reported: 2013-07-08 19:52 UTC by sthirugn@redhat.com
Modified: 2014-06-30 20:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-30 20:12:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Subscriptions tupane errors (deleted)
2013-07-08 19:54 UTC, sthirugn@redhat.com
no flags Details
Manifest upload UI error (deleted)
2013-07-08 19:54 UTC, sthirugn@redhat.com
no flags Details

Description sthirugn@redhat.com 2013-07-08 19:52:05 UTC
Description of problem:
Subscriptions nutupane does not work as intended

Version-Release number of selected component (if applicable):
* candlepin-0.8.16-1.el6.noarch
* candlepin-cert-consumer-hp-ml370g6-01.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-tomcat6-0.8.16-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.107.43fee0b.el6.noarch
* katello-cli-common-1.4.2-1.git.107.43fee0b.el6.noarch
* katello-common-1.4.2-1.git.825.a0f965d.el6.noarch
* katello-configure-1.4.3-1.git.67.f71e590.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.825.a0f965d.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.825.a0f965d.el6.noarch
* katello-headpin-1.4.2-1.git.825.a0f965d.el6.noarch
* katello-headpin-all-1.4.2-1.git.825.a0f965d.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Navigate to UI -> Subscriptions -> Red Hat Subscriptions

Actual results:
1. Click on a Subscription -> The details of the selected subscription is not displayed
2. Clicking on imported manifest displays a partial page (not able to scroll down to see the rest of the page)
3. In Import Manifest -> Details or Import or History tabs are not functional
4. In Import Manifest modal -> Repository URL, Upstream Subscription Management Application, Manifest File fields are misaligned
5. In Import Manifest modal, 'Close' link is not functional
6. In Import Manifest modal, select a manifest file by clicking on 'Browse Button...' and click 'Upload'. This displays a page with message: {"state":"running"}

Expected results:
The above mentioned issues should not occur

Additional info:

Comment 1 sthirugn@redhat.com 2013-07-08 19:54:05 UTC
Created attachment 770640 [details]
Subscriptions tupane errors

Comment 2 sthirugn@redhat.com 2013-07-08 19:54:30 UTC
Created attachment 770641 [details]
Manifest upload UI error

Comment 3 sthirugn@redhat.com 2014-06-27 21:17:45 UTC
Bug still exists.  But happens only in SAM 1.4 experimental UI mode. SAM 2.0 will get a new UI anyways. Ok to close this IMO. Requesting Bryan for confirmation.

Comment 4 Bryan Kearney 2014-06-30 20:12:31 UTC
Closed!


Note You need to log in before you can comment on or make changes to this bug.