Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 98224 - ssl.h includes krb5.h which is not in the standard include path
Summary: ssl.h includes krb5.h which is not in the standard include path
Keywords:
Status: CLOSED DUPLICATE of bug 82369
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssl
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-28 08:33 UTC by Martin Norback
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:56:54 UTC


Attachments (Terms of Use)

Description Martin Norback 2003-06-28 08:33:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
If I include openssl/ssl.h I get the following error message:

In file included from /usr/include/openssl/ssl.h:179,
/usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory

krb5.h is installed, but not in a standard place it is in /usr/kerberos/include

I am not particulary interested in kerberos, I only want openssl so I really
shouldn't need to add an extra -I/usr/kerberos/include to my program (how will
an openssl program know that it needs to do that?)

The fix I did on my system was to #define OPENSSL_NO_KRB5 on top of ssl.h, this
is not a very pretty solution.


Version-Release number of selected component (if applicable):
openssl-devel-0.9.7a-11

How reproducible:
Always

Steps to Reproduce:
1. #include <openssl.h>
2.
3.
    

Actual Results:  In file included from /usr/include/openssl/ssl.h:179,
/usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory


Additional info:

Comment 1 Joe Orton 2003-07-09 19:50:47 UTC

*** This bug has been marked as a duplicate of 82369 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:56:54 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.