Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 982088 - Delta RPM messages sent by yum-cron
Summary: Delta RPM messages sent by yum-cron
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 19
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-08 06:32 UTC by Jan ONDREJ
Modified: 2014-06-09 11:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-09 11:17:34 UTC


Attachments (Terms of Use)

Description Jan ONDREJ 2013-07-08 06:32:19 UTC
Description of problem:
Again, some messages from yum-cron has been sent to wrong output and this causes yum-cron to send unnecessary messages.

Version-Release number of selected component (if applicable):
yum-3.4.3-99.fc19.noarch

How reproducible:
after each update from yum-cron

Actual results:
From: Anacron <root>
Date: Mon,  8 Jul 2013 03:52:04 +0200 (CEST)
To: root
Subject: Anacron job 'cron.daily' on work

/etc/cron.daily/0yum-daily.cron:

Delta RPMs reduced 4.6 M of updates to 2.1 M (54% saved)
delta does not match installed data
Finishing delta rebuilds of 4 package(s) (4.4 M)
Some delta RPMs failed to download or rebuild. Retrying..

Expected results:
--- no mail ---

Additional info:

Comment 1 Jan ONDREJ 2013-07-09 06:06:41 UTC
Presto has similar problem. Please fix this too:

No Presto metadata available for xxxxxxxxx

Comment 2 Zdeněk Pavlas 2013-07-09 08:37:36 UTC
http://lists.baseurl.org/pipermail/yum-devel/2012-November/009718.html

This is an old bug.. see BZ 873428, my patch and discussion.  log messages with "info" log level SHOULD be printed with -q or -d0 Yum options (used by yum cron)

Note that the "delta does not match installed data" and "Some delta RPMs failed to download or rebuild. Retrying.." messages are useful warnings and it's probably ok to report this.

Comment 3 Jan ONDREJ 2013-07-09 11:07:41 UTC
This patch has been rejected and bug is still present. Reopening.

Comment 4 Jan ONDREJ 2013-07-10 12:02:24 UTC
Another message:

Subject: Cron <root@work> run-parts /etc/cron.hourly                            

/etc/cron.hourly/0yum-hourly.cron:

BDB2053 Freeing read locks for locker 0xbd3: 7976/139765745551360
BDB2053 Freeing read locks for locker 0xbd4: 7976/139765745551360
BDB2053 Freeing read locks for locker 0xbd5: 7976/139765745551360
BDB2053 Freeing read locks for locker 0xbd6: 7976/139765745551360

Comment 5 Panu Matilainen 2013-07-10 12:07:49 UTC
Those "freeing read locks" messages come from rpm, telling you that something in the system has been a bad boy and left stale rpmdb locks behind it.

Comment 6 Jan ONDREJ 2013-07-24 05:40:50 UTC
And more messages. These are more disturbing, because they are comming hourly.

Subject: Cron <root@work> run-parts /etc/cron.hourly                            

/etc/cron.hourly/0yum-hourly.cron:

Not using downloaded repomd.xml because it is older than what we have:
  Current   : Sat Jun 29 21:38:11 2013
  Downloaded: Sat Jun 29 00:56:36 2013

Comment 7 Zdeněk Pavlas 2013-07-24 07:52:30 UTC
This is something yum *should* complain about- a repository was replaced with an older version.  Sadly there's no repoid in the message, but you can probably find it by greping the timestamp.  What's the output of:

$ python -c 'import time; print int(time.mktime(time.strptime("Sat Jun 29 21:38:11 2013")))'
1372534691
$ grep 1372534691 $(find /var/cache/yum -name repomd.xml)

Comment 8 Jan ONDREJ 2013-08-05 06:51:53 UTC
I see new options in yum-3.4.3-104.fc19.noarch.

[base]
# Use this to filter Yum core messages
# -4: critical
# -3: critical+errors
# -2: critical+errors+warnings (default)
debuglevel = -2

Was this problem solved by these options?

Comment 9 Zdeněk Pavlas 2013-08-05 07:10:53 UTC
Yes. For some reason, bohdi didn't send BZ messages.

Comment 10 Jan ONDREJ 2013-08-22 05:23:46 UTC
My current settings are:

[ondrejj@ftp ~]$ grep debuglevel /etc/yum/yum-cron.conf
debuglevel = -4

But still getting this message from cron:

Subject: Anacron job 'cron.daily' on ftp.upjs.sk                                

/etc/cron.daily/0yum-daily.cron:

The following updates will be applied on ftp.upjs.sk:
================================================================================
 Package                Arch        Verzia              Repozitár          Veľ. 
================================================================================
Aktualizuje sa:
 libusb                 x86_64      1:0.1.5-2.fc19      updates-upjs       35 k
 tcp_wrappers-libs      x86_64      7.6-75.fc19         updates-upjs       66 k

Zhrnutie transakcie
================================================================================
Upgrade  2 Balíčky
The updates were successfully applied

Is this message really critical? It will send me one email per server for each server with available updates.
Can I stop sending these messages?

Comment 11 Zdeněk Pavlas 2013-08-26 10:41:58 UTC
Yes, these messages are not conditional..  It'd be nice to be able to turn this off. http://lists.baseurl.org/pipermail/yum-devel/2013-August/010334.html

Comment 12 Jan ONDREJ 2013-10-09 05:40:28 UTC
New yum release, new messages:

Subject: Cron <root@work> run-parts /etc/cron.hourly                            

/etc/cron.hourly/0yum-hourly.cron:

Načítané zásuvné moduly:auto-update-debuginfo, langpacks

These are send hourly even if no updates are applied. :-(

Version-Release number of selected component (if applicable):
yum-3.4.3-111.fc19.noarch

Curious, that there is no change in yum version, only in release. Zdenek, can you please apply your patches to avoid all unnecessary messages?

Comment 13 Zdeněk Pavlas 2013-10-09 08:10:55 UTC
[ondrejj@ftp ~]$ grep debuglevel /etc/cron.hourly/0yum-hourly.cron
?

If it's not there, please set it to -2 (you should see only warning then).
debuglevel = -2 is set in the default yum-cron-hourly.conf but RPM keeps the old one if modified.


Note You need to log in before you can comment on or make changes to this bug.