Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981986 - [abrt] gnucash-2.4.13-1.fc18: set_gdate_val: Process /usr/bin/gnucash was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnucash-2.4.13-1.fc18: set_gdate_val: Process /usr/bin/gnucash was kil...
Alias: None
Product: Fedora
Classification: Fedora
Component: gnucash
Version: 18
Hardware: x86_64
OS: Unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
Whiteboard: abrt_hash:4d96bc741cafec05b5393ba05bf...
Depends On:
TreeView+ depends on / blocked
Reported: 2013-07-07 14:34 UTC by Brent R Brian
Modified: 2014-03-17 03:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2013-07-13 16:23:45 UTC

Attachments (Terms of Use)
File: backtrace (deleted)
2013-07-07 14:34 UTC, Brent R Brian
no flags Details
File: cgroup (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
File: core_backtrace (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
File: dso_list (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
File: environ (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
File: gconf_subtree (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
File: limits (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
File: maps (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
File: open_fds (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
File: proc_pid_status (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
File: var_log_messages (deleted)
2013-07-07 14:35 UTC, Brent R Brian
no flags Details
log file from: gnucash --nofile --debug --extra --logto ~/gnucash.log (deleted)
2013-07-07 15:15 UTC, Brent R Brian
no flags Details

Description Brent R Brian 2013-07-07 14:34:55 UTC
Description of problem:
I have two accounting files, one opens fine (the smaller), the other (larger) crashes silently.

Version-Release number of selected component:

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        gnucash
crash_function: set_gdate_val
executable:     /usr/bin/gnucash
kernel:         3.9.6-200.fc18.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 set_gdate_val at gnc-slots-sql.c:604
 #1 load_date at gnc-backend-sql.c:2104
 #2 gnc_sql_load_object at gnc-backend-sql.c:2479
 #3 load_slot_for_list_item at gnc-slots-sql.c:902
 #4 gnc_sql_slots_load_for_list at gnc-slots-sql.c:962
 #5 query_transactions at gnc-transaction-sql.c:421
 #6 gnc_sql_transaction_load_all_tx at gnc-transaction-sql.c:901
 #7 g_hash_table_foreach_sorted at qofutil.c:47
 #8 qof_object_foreach_backend at qofobject.c:398
 #9 gnc_sql_load at gnc-backend-sql.c:261

Comment 1 Brent R Brian 2013-07-07 14:34:59 UTC
Created attachment 769994 [details]
File: backtrace

Comment 2 Brent R Brian 2013-07-07 14:35:02 UTC
Created attachment 769995 [details]
File: cgroup

Comment 3 Brent R Brian 2013-07-07 14:35:05 UTC
Created attachment 769996 [details]
File: core_backtrace

Comment 4 Brent R Brian 2013-07-07 14:35:08 UTC
Created attachment 769997 [details]
File: dso_list

Comment 5 Brent R Brian 2013-07-07 14:35:11 UTC
Created attachment 769998 [details]
File: environ

Comment 6 Brent R Brian 2013-07-07 14:35:14 UTC
Created attachment 769999 [details]
File: gconf_subtree

Comment 7 Brent R Brian 2013-07-07 14:35:18 UTC
Created attachment 770000 [details]
File: limits

Comment 8 Brent R Brian 2013-07-07 14:35:21 UTC
Created attachment 770001 [details]
File: maps

Comment 9 Brent R Brian 2013-07-07 14:35:25 UTC
Created attachment 770002 [details]
File: open_fds

Comment 10 Brent R Brian 2013-07-07 14:35:28 UTC
Created attachment 770003 [details]
File: proc_pid_status

Comment 11 Brent R Brian 2013-07-07 14:35:31 UTC
Created attachment 770004 [details]
File: var_log_messages

Comment 12 Brent R Brian 2013-07-07 15:13:29 UTC
I doubt this helps much, but here goes.

I have two files, sqlite, one is rather small, the other (that crashes) is large.

Neither of the two closed with any warning or error (that I know of) when last used.

I have had updates recently, almost every time I log on.

I can open the smaller file, no issues.  Larger one fails.

As a sanity check, I:

  removed gnucash (yum remove)
  installed gnucash (yum install)

then I ran gnucash from command line:

  gnucash --nofile --debug --extra --logto ~/gnucash.log

and then opened my file (largest one), it failes.

The log file seems to say the same thing the crash report does, but I attached it anyway.

Comment 13 Brent R Brian 2013-07-07 15:15:10 UTC
Created attachment 770017 [details]
log file from: gnucash --nofile --debug --extra --logto ~/gnucash.log

added log file.

Comment 14 Bill Nottingham 2013-07-09 20:53:45 UTC
Is there some version that *doesn't* crash on that file?

Comment 15 Brent R Brian 2013-07-11 10:41:55 UTC
Actually, the "file" is SQLite ... I did a query on the record in question and it seems fine ... the transaction log file seems fine.

Comment 16 Bill Nottingham 2013-07-11 14:37:27 UTC
I'm sorry, restating - is there some version of GnuCash which starts correctly with that file?

Comment 17 Brent R Brian 2013-07-13 16:23:45 UTC
I tried the file with Mint 15 and it failed.

I restored the file from backup, replayed the log files to bring it up to date, and all seems well ... no idea what happened ... system stable and nothing ever crashes ...  seems odd that it appeared after updates ... no matter.

Note You need to log in before you can comment on or make changes to this bug.