Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981816 - [abrt] gnome-boxes-3.8.3-1.fc19: cogl_matrix_entry_ref: Process /usr/bin/gnome-boxes was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnome-boxes-3.8.3-1.fc19: cogl_matrix_entry_ref: Process /usr/bin/gnom...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-boxes
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christophe Fergeau
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bfed8e9ceceb15d84a5640ccab2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-06 00:04 UTC by Václav Mocek
Modified: 2013-08-09 08:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-09 08:49:28 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2013-07-06 00:04 UTC, Václav Mocek
no flags Details
File: cgroup (deleted)
2013-07-06 00:04 UTC, Václav Mocek
no flags Details
File: core_backtrace (deleted)
2013-07-06 00:04 UTC, Václav Mocek
no flags Details
File: dso_list (deleted)
2013-07-06 00:04 UTC, Václav Mocek
no flags Details
File: environ (deleted)
2013-07-06 00:04 UTC, Václav Mocek
no flags Details
File: limits (deleted)
2013-07-06 00:05 UTC, Václav Mocek
no flags Details
File: maps (deleted)
2013-07-06 00:05 UTC, Václav Mocek
no flags Details
File: open_fds (deleted)
2013-07-06 00:05 UTC, Václav Mocek
no flags Details
File: proc_pid_status (deleted)
2013-07-06 00:05 UTC, Václav Mocek
no flags Details
File: var_log_messages (deleted)
2013-07-06 00:05 UTC, Václav Mocek
no flags Details

Description Václav Mocek 2013-07-06 00:04:27 UTC
Description of problem:
An attempt to run Boxes after the update from F18.

Version-Release number of selected component:
gnome-boxes-3.8.3-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        gnome-boxes
crash_function: cogl_matrix_entry_ref
executable:     /usr/bin/gnome-boxes
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 cogl_matrix_entry_ref at ./cogl-matrix-stack.c:332
 #1 cogl_matrix_stack_new at ./cogl-matrix-stack.c:662
 #2 _cogl_framebuffer_init at ./cogl-framebuffer.c:119
 #3 cogl_onscreen_new at ./cogl-onscreen.c:101
 #4 clutter_stage_x11_realize at x11/clutter-stage-x11.c:589
 #5 clutter_stage_realize at ./clutter-stage.c:767
 #6 _g_closure_invoke_va at gclosure.c:840
 #9 clutter_actor_realize at ./clutter-actor.c:1930
 #10 _clutter_stage_manager_set_default_stage at ./clutter-stage-manager.c:226
 #11 clutter_stage_constructed at ./clutter-stage.c:1682

Comment 1 Václav Mocek 2013-07-06 00:04:34 UTC
Created attachment 769441 [details]
File: backtrace

Comment 2 Václav Mocek 2013-07-06 00:04:39 UTC
Created attachment 769442 [details]
File: cgroup

Comment 3 Václav Mocek 2013-07-06 00:04:45 UTC
Created attachment 769443 [details]
File: core_backtrace

Comment 4 Václav Mocek 2013-07-06 00:04:52 UTC
Created attachment 769444 [details]
File: dso_list

Comment 5 Václav Mocek 2013-07-06 00:04:58 UTC
Created attachment 769445 [details]
File: environ

Comment 6 Václav Mocek 2013-07-06 00:05:02 UTC
Created attachment 769446 [details]
File: limits

Comment 7 Václav Mocek 2013-07-06 00:05:08 UTC
Created attachment 769447 [details]
File: maps

Comment 8 Václav Mocek 2013-07-06 00:05:13 UTC
Created attachment 769448 [details]
File: open_fds

Comment 9 Václav Mocek 2013-07-06 00:05:17 UTC
Created attachment 769449 [details]
File: proc_pid_status

Comment 10 Václav Mocek 2013-07-06 00:05:21 UTC
Created attachment 769450 [details]
File: var_log_messages

Comment 11 Svetlozar Argirov 2013-07-28 16:22:53 UTC
This happens to me also on a new Fedora 19 installation.  After installing the proprietary AMD drivers, gnome-boxes crashes every single time with this errors.

From the dso_list you can see that what gets loaded for GL library is :
/usr/lib64/libEGL.so.1.0.0  ( on my system is /lib64/libEGL.so.1)

$ yum provides /lib64/libEGL.so.1
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
mesa-libEGL-9.2-0.14.20130723.fc19.x86_64 : Mesa libEGL runtime libraries
Repo        : @updates
Matched from:
Filename    : /lib64/libEGL.so.1

So.. cogl is loading EGL from mesa , which obviously doesn't work with the AMD drivers.

Downloading AMD OpenGL ES SDK  from, http://developer.amd.com/tools-and-sdks/graphics-development/amd-opengl-es-sdk/ , and using libEGL from there solves the problem. Gnome boxes works as expected.
The only strange thing is setting LD_LIBRARY_PATH doesn't now work , I have no idea why, but using LD_PRELOAD did the trick :

LD_PRELOAD=./libEGL.so gnome-boxes

Comment 12 Václav Mocek 2013-07-28 18:41:55 UTC
(In reply to Svetlozar Argirov from comment #11)
> This happens to me also on a new Fedora 19 installation.  After installing
> the proprietary AMD drivers, gnome-boxes crashes every single time with this
> errors.
Confirmed.

> Downloading AMD OpenGL ES SDK  from,
> http://developer.amd.com/tools-and-sdks/graphics-development/amd-opengl-es-
> sdk/ , and using libEGL from there solves the problem. Gnome boxes works as
> expected.
The problem seems to be in Clutter library, it fails to initialize.

> The only strange thing is setting LD_LIBRARY_PATH doesn't now work , I have
> no idea why, but using LD_PRELOAD did the trick :
> 
> LD_PRELOAD=./libEGL.so gnome-boxes
A nice trick, I will try that.

Comment 13 Christophe Fergeau 2013-07-29 08:34:33 UTC
Sounds like a bug in the proprietary driver package or something like this?

Comment 14 Svetlozar Argirov 2013-08-09 08:45:02 UTC
Yes. Its in the driver package.

I posted a bug  on the rpm fusion tracker about it, with a patch that solves it. 

https://bugzilla.rpmfusion.org/show_bug.cgi?id=2914


Note You need to log in before you can comment on or make changes to this bug.