Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981740 - Cannot remove selinux
Summary: Cannot remove selinux
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libsemanage
Version: 19
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-05 16:27 UTC by Scott Baker
Modified: 2013-07-24 03:23 UTC (History)
3 users (show)

Fixed In Version: libsemanage-2.1.10-6.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-24 03:23:43 UTC


Attachments (Terms of Use)

Description Scott Baker 2013-07-05 16:27:56 UTC
Description of problem:
I don't use selinux, I find it complicated problematic. In previous versions of Fedora, up to Fedora 18, I was able to yum remove selinux* and it would remove all selinux components. In Fedora 19, when I try that command it fails as it pulls in systemd as a dependency.

Before the answer is "just disable selinux, don't try and remove it" I'll tell you why I remove it, instead of disabling it. The "yum updates" for selinux components are large, and take a long time to install (updating all the file contexts?). Basically any selinux update really slows down my yum updates. Since I don't use it at all, I'd really like to be able to remove it completely.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-3.12.1-57.fc19.noarch
selinux-policy-3.12.1-57.fc19.noarch

How reproducible:
Easy

Steps to Reproduce:
1. Install F19
2. Try and yum remove selinux*

Actual results:
Fails due a systemd dependancy

Expected results:
It removes selinux

Comment 1 Daniel Walsh 2013-07-09 15:17:35 UTC
You should be able to remove

selinux-policy-targeted

libsemanage grew a dependency on selinux-policy, which I will remove. and reverse it.  selinux-policy should rely on libsemanage.

Comment 2 Daniel Walsh 2013-07-09 15:19:35 UTC
fixed in libsemanage-2.1.10-6.fc19

Comment 3 Scott Baker 2013-07-09 16:43:02 UTC
You were right, I can remove selinux-policy-targeted, but not selinux-policy. We're halfway there.

Where can I get libsemanage-2.1.10-6.fc19 to test with?

Comment 4 Fedora Update System 2013-07-09 20:15:46 UTC
libsemanage-2.1.10-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libsemanage-2.1.10-6.fc19

Comment 5 Fedora Update System 2013-07-11 02:35:31 UTC
Package libsemanage-2.1.10-6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libsemanage-2.1.10-6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12756/libsemanage-2.1.10-6.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-07-24 03:23:43 UTC
libsemanage-2.1.10-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.