Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981694 - SELinux is preventing /usr/java/jre1.7.0_25/bin/java from 'create' accesses on the file hs_err_pid1749.log.
Summary: SELinux is preventing /usr/java/jre1.7.0_25/bin/java from 'create' accesses o...
Keywords:
Status: CLOSED DUPLICATE of bug 964309
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 19
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5a2f957a9d8643990e65c6e70b8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-05 13:59 UTC by Massao
Modified: 2013-07-10 23:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-10 23:05:48 UTC


Attachments (Terms of Use)

Description Massao 2013-07-05 13:59:39 UTC
Description of problem:
SELinux is preventing /usr/java/jre1.7.0_25/bin/java from 'create' accesses on the file hs_err_pid1749.log.

*****  Plugin mozplugger (99.1 confidence) suggests  *************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests  ***************************

If você acredita que o java deva ser permitido acesso de create em hs_err_pid1749.log file  por default.
Then você precisa reportar este como um erro.
Você pode gerar um módulo de política local para permitir este acesso.
Do
permitir este acesso agora executando:
# grep java /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                hs_err_pid1749.log [ file ]
Source                        java
Source Path                   /usr/java/jre1.7.0_25/bin/java
Port                          <Desconhecido>
Host                          (removed)
Source RPM Packages           jre-1.7.0_25-fcs.i586
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-57.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.i686.PAE #1 SMP Thu
                              Jun 27 19:29:30 UTC 2013 i686 i686
Alert Count                   2
First Seen                    2013-07-05 10:57:20 BRT
Last Seen                     2013-07-05 10:57:32 BRT
Local ID                      5af6ca1a-67f9-4e58-a0b7-b595e19f9e38

Raw Audit Messages
type=AVC msg=audit(1373032652.833:416): avc:  denied  { create } for  pid=1804 comm="java" name="hs_err_pid1749.log" scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file


type=SYSCALL msg=audit(1373032652.833:416): arch=i386 syscall=open success=no exit=EACCES a0=b74fc040 a1=242 a2=1b6 a3=c items=0 ppid=1735 pid=1804 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=java exe=/usr/java/jre1.7.0_25/bin/java subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: java,mozilla_plugin_t,user_home_t,file,create

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.i686.PAE
type:           libreport

Potential duplicate: bug 964309

Comment 1 Daniel Walsh 2013-07-10 23:05:48 UTC

*** This bug has been marked as a duplicate of bug 964309 ***


Note You need to log in before you can comment on or make changes to this bug.