Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981613 - UI should truncate the name while creating the filter with long name
Summary: UI should truncate the name while creating the filter with long name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
medium
low vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Sachin Ghai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-05 09:34 UTC by Sachin Ghai
Modified: 2014-04-24 17:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-24 17:08:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
filter name is not trucated (deleted)
2013-07-05 09:34 UTC, Sachin Ghai
no flags Details
long filter name is truncated (deleted)
2013-10-16 13:00 UTC, Sachin Ghai
no flags Details

Description Sachin Ghai 2013-07-05 09:34:42 UTC
Created attachment 769169 [details]
filter name is not trucated

Description of problem:
Created a filter with long name to check the maximum allowed limit. The filter was created with two related issues:
1. the name was not truncated properly.
2. the name appears on next line  however, it should appear on same line along with checkbox


Version-Release number of selected component (if applicable):
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-1.4.2-1.git.98.3567fd4.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
signo-katello-0.0.9-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.761.9817788.el6.noarch
katello-1.4.2-1.git.761.9817788.el6.noarch
katello-repos-1.4.2-1.el6.noarch
katello-common-1.4.2-1.git.761.9817788.el6.noarch
katello-all-1.4.2-1.git.761.9817788.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.98.3567fd4.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-configure-1.4.3-1.git.65.63e692c.el6.noarch
katello-glue-pulp-1.4.2-1.git.761.9817788.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. create a content-view
2. define a filter with long name.


Actual results:
the name was not truncated properly.
name appears on next line

Expected results:
should appear on same line along with checkbox. 

Additional info:

Comment 1 RHEL Product and Program Management 2013-09-17 04:24:16 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Brad Buckingham 2013-09-19 19:47:08 UTC
katello pull request:

https://github.com/Katello/katello/pull/3008

Comment 7 Sachin Ghai 2013-10-16 12:59:30 UTC
Verified with snap5 compose 2..


signo-katello-0.0.22-2.el6sat.noarch
katello-configure-foreman-proxy-1.4.7-3.el6sat.noarch
katello-cli-common-1.4.3-20.el6sat.noarch
katello-configure-foreman-1.4.7-3.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
katello-glue-elasticsearch-1.4.6-31.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.14-5.el6sat.noarch
katello-glue-pulp-1.4.6-31.el6sat.noarch
katello-all-1.4.6-31.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-1.4.6-31.el6sat.noarch
katello-foreman-all-1.4.6-31.el6sat.noarch
katello-configure-1.4.7-3.el6sat.noarch
katello-cli-1.4.3-20.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.7-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-common-1.4.6-31.el6sat.noarch
katello-glue-candlepin-1.4.6-31.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch

UI truncating the long filter name. Please see the attached snapshot.

Comment 8 Sachin Ghai 2013-10-16 13:00:44 UTC
Created attachment 812908 [details]
long filter name is truncated

Comment 9 Bryan Kearney 2014-04-24 17:08:30 UTC
This was verified and delivered with MDP2. Closing it out.


Note You need to log in before you can comment on or make changes to this bug.