Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 98159 - TB sre.py:143:sub:TypeError: expected string or buffer
Summary: TB sre.py:143:sub:TypeError: expected string or buffer
Keywords:
Status: CLOSED DUPLICATE of bug 88147
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-27 04:06 UTC by John Reiser
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:56:53 UTC


Attachments (Terms of Use)
saved crash report via python dialog (deleted)
2003-06-27 04:08 UTC, John Reiser
no flags Details
saved crash report via python dialog box (2nd try) (deleted)
2003-06-27 04:08 UTC, John Reiser
no flags Details

Description John Reiser 2003-06-27 04:06:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
redhat-config-network (graphical; invoked from GNOME panel System Settings >
Network) crashed when clicking Forward on the ISP settings page for a new modem
device (/dev/input/ttyACM0).  eth0 was already configured and active.


Version-Release number of selected component (if applicable):
redhat-config-network-1.2.10-1

How reproducible:
Always

Steps to Reproduce:
1. (GNOME panel; as root) System Settings > Network
2. (eth0 already configured and active) New device; Modem; Forward
3. [Warning: no modem found.  It's a hot-plugged USB modem, and
/proc/bus/usb/devices says that it _is_ there.]
4. Select /dev/input/ttyACM0, 115200 baud, hardware flowcontrol, medium modem
volume, use TouchTone;  Forward
5. Enter 3 digit Area Code, 7 digit Phone (xxx yyyy), Provider name (7
characters), User name (19 characters: uuuuuuu@ppppppp.net), 8 character
password; Forward
6. Crash reported via python dialog box.
    

Actual Results:  crash

Expected Results:  no crash

Additional info:# rpm -qa | grep python
python-2.2.2-26
libxml2-python-2.5.4-1
gnome-python2-bonobo-1.99.14-5
python-devel-2.2.2-26
python-optik-1.4-2
rpm-python-4.2-0.69
gnome-python2-gtkhtml2-1.99.14-5
gnome-python2-canvas-1.99.14-5
gnome-python2-1.99.14-5
$

Comment 1 John Reiser 2003-06-27 04:08:07 UTC
Created attachment 92647 [details]
saved crash report via python dialog

Comment 2 John Reiser 2003-06-27 04:08:42 UTC
Created attachment 92648 [details]
saved crash report via python dialog box (2nd try)

Comment 3 John Reiser 2003-06-27 04:44:37 UTC
redhat-config-network-tui  worked well enough to enter ISP settings, but did not
offer all the options (DNS, etc.).  Finally redhat-config-network did allow
editing all parameters for the modem connection.


Comment 4 Harald Hoyer 2003-06-27 09:51:56 UTC
Please try the update from
http://people.redhat.com/harald/redhat-config-network

*** This bug has been marked as a duplicate of 88147 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:56:53 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.