Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981587 - /var/log/keystone/keystone.log has incorrect ownership
Summary: /var/log/keystone/keystone.log has incorrect ownership
Keywords:
Status: CLOSED DUPLICATE of bug 946915
Alias: None
Product: Fedora
Classification: Fedora
Component: openstack-packstack
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Derek Higgins
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-05 08:17 UTC by Jonathan Barber
Modified: 2013-07-08 10:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-08 10:01:48 UTC


Attachments (Terms of Use)

Description Jonathan Barber 2013-07-05 08:17:13 UTC
Description of problem:
Packstack fails to start the keystone service because the file /var/log/keystone/keystone.log has ownership root:root.

Version-Release number of selected component (if applicable):
openstack-packstack-2013.1.1-0.3.dev527.fc19.noarch
openstack-keystone-2013.1.1-1.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install f19 @core + "yum install openstack-packstack"
1. run packstack

Actual results:
Packstack reports:
ERROR : Error during puppet run : Error: Could not start Service[keystone]: Execution of '/sbin/service openstack-keystone start' returned 1: 
Please check log file /var/tmp/packstack/20130705-084127-0gy_H4/openstack-setup.log for more information

/var/log/messages reports:
Jul  5 08:42:41 cas08 keystone-all[12547]: Traceback (most recent call last):
Jul  5 08:42:41 cas08 keystone-all[12547]: File "/usr/bin/keystone-all", line 85, in <module>
Jul  5 08:42:41 cas08 keystone-all[12547]: config.setup_logging(CONF)
Jul  5 08:42:41 cas08 keystone-all[12547]: File "/usr/lib/python2.7/site-packages/keystone/common/config.py", line 119, in setup_logging
Jul  5 08:42:41 cas08 keystone-all[12547]: handler = logging.WatchedFileHandler(logfile)
Jul  5 08:42:41 cas08 keystone-all[12547]: File "/usr/lib64/python2.7/logging/handlers.py", line 392, in __init__
Jul  5 08:42:41 cas08 keystone-all[12547]: logging.FileHandler.__init__(self, filename, mode, encoding, delay)
Jul  5 08:42:41 cas08 keystone-all[12547]: File "/usr/lib64/python2.7/logging/__init__.py", line 902, in __init__
Jul  5 08:42:41 cas08 keystone-all[12547]: StreamHandler.__init__(self, self._open())
Jul  5 08:42:41 cas08 keystone-all[12547]: File "/usr/lib64/python2.7/logging/__init__.py", line 925, in _open
Jul  5 08:42:41 cas08 keystone-all[12547]: stream = open(self.baseFilename, self.mode)
Jul  5 08:42:41 cas08 keystone-all[12547]: IOError: [Errno 13] Permission denied: '/var/log/keystone/keystone.log'
Jul  5 08:42:41 cas08 systemd[1]: openstack-keystone.service: main process exited, code=exited, status=1/FAILURE
Jul  5 08:42:41 cas08 systemd[1]: Failed to start OpenStack Identity Service (code-named Keystone).

Expected results:
Keystone should start

Additional info:
I believe this is already fixed in the upstream git repo for packstack, I'm mainly reporting this here in case anyone else runs into the problem.

Ah, it already has a bz here https://bugzilla.redhat.com/show_bug.cgi?id=946915

Comment 1 Martin Magr 2013-07-08 10:01:48 UTC

*** This bug has been marked as a duplicate of bug 946915 ***


Note You need to log in before you can comment on or make changes to this bug.