Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981536 - selinux error every time chrome is started
Summary: selinux error every time chrome is started
Keywords:
Status: CLOSED DUPLICATE of bug 960792
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-05 05:37 UTC by Steevithak
Modified: 2013-07-08 18:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-08 18:59:45 UTC


Attachments (Terms of Use)

Description Steevithak 2013-07-05 05:37:39 UTC
Description of problem:
After upgrading to Fedora 19 (from F18) and re-installing the Google Chrome web browser, an selinux error is generated each time Chrome starts. This was not a problem on earlier versions of Fedora so it seems to be some sort of policy bug associated with Fedora 19.

Version-Release number of selected component (if applicable):
Fedora 19


How reproducible:
always

Steps to Reproduce:
1. Install Fedora 19
2. Install Chrome
3. start Chrome

Actual results:
selinux error message appears as Chrome starts

Expected results:
selinux should not generate an error

Additional info:

Comment 1 Daniel Walsh 2013-07-05 11:57:12 UTC
What AVC's are you seein?

Comment 2 Steevithak 2013-07-08 15:54:40 UTC
This bug is now cropping up on all my F18 and F19 boxes. When I get the SELinux alert, if I click "Show" followed by "Details" I get the following. (also note the first line of the following error dump seems to contain grammatical errors)

SELinux is preventing /opt/google/chrome/chrome from create access on the file libpeerconnection.log.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that chrome should be allowed create access on the libpeerconnection.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep chrome /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                libpeerconnection.log [ file ]
Source                        chrome
Source Path                   /opt/google/chrome/chrome
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           google-chrome-stable-28.0.1500.71-209842.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-59.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain 3.9.9-301.fc19.x86_64
                              #1 SMP Thu Jul 4 15:10:36 UTC 2013 x86_64 x86_64
Alert Count                   22
First Seen                    2013-07-04 23:28:44 CDT
Last Seen                     2013-07-08 10:47:59 CDT
Local ID                      4d66d393-31be-4a43-93c6-4dd1cd24aa1e

Raw Audit Messages
type=AVC msg=audit(1373298479.809:448): avc:  denied  { create } for  pid=2208 comm="chrome" name="libpeerconnection.log" scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1373298479.809:448): arch=x86_64 syscall=open success=no exit=EACCES a0=7fe3f8504138 a1=441 a2=1b6 a3=ffffe000 items=0 ppid=0 pid=2208 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=chrome exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)

Hash: chrome,chrome_sandbox_t,user_home_dir_t,file,create

Comment 3 Daniel Walsh 2013-07-08 18:59:45 UTC

*** This bug has been marked as a duplicate of bug 960792 ***


Note You need to log in before you can comment on or make changes to this bug.