Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981302 - RHEV Host Installation fails
Summary: RHEV Host Installation fails
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-host-deploy
Classification: oVirt
Component: Plugins.VDSM
Version: 1.1.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Alon Bar-Lev
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-04 12:35 UTC by Andreas Muehlemann
Modified: 2015-09-20 20:37 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-26 14:51:35 UTC
oVirt Team: ---
pm-rhel: devel_ack?


Attachments (Terms of Use)

Description Andreas Muehlemann 2013-07-04 12:35:56 UTC
Description of problem:
While installing a virtualization host, the installation stopps with the error

'Cannot locate vdsm package, RuntimeError: Cannot locate vdsm package, possible cause is incorrect channels'

I do not find the vdsm package in any of the Red Hat Channels. Which channel is needed or is the package missing?

Version-Release number of selected component (if applicable):
RHEL 6.4

How reproducible:


Steps to Reproduce:
1. prepared the host, set RHN channels rhel-x86_64-server-6 and rhel-x86_64-rhev-agent-6-server
2. in RHEV Management GUI, add Host and start installation
3. Host installation failes

Actual results:
Host installation fails

Expected results:
Host installation completed

Additional info:
part of the logfile

2013-07-04 13:38:20 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:215 DIALOG:SEND       Traceback (most recent call last):
2013-07-04 13:38:20 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:215 DIALOG:SEND         File "/tmp/ovirt-uBaZkCOT7l/pythonlib/otopi/context.py", line 120, in _executeMethod
2013-07-04 13:38:20 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:215 DIALOG:SEND           method['method']()
2013-07-04 13:38:20 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:215 DIALOG:SEND         File "/tmp/ovirt-uBaZkCOT7l/otopi-plugins/ovirt-host-deploy/vdsm/packages.py", line 65, in _validation
2013-07-04 13:38:20 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:215 DIALOG:SEND           'Cannot locate vdsm package, '
2013-07-04 13:38:20 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:215 DIALOG:SEND       RuntimeError: Cannot locate vdsm package, possible cause is incorrect channels
2013-07-04 13:38:20 DEBUG otopi.plugins.otopi.dialog.machine dialog.__logString:215 DIALOG:SEND       2013-07-04 13:38:20 ERROR otopi.context context._executeMethod:139 Failed to execute stage 'Setup validation': Cannot locate vdsm package, possible cause is incorrect channels

Comment 2 Bill Nottingham 2013-07-09 19:58:31 UTC
How were you trying to install RHEV?

Comment 3 RHEL Product and Program Management 2013-10-13 23:25:02 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 4 Brian Lane 2014-01-06 18:20:55 UTC
This isn't an anaconda traceback. Whatever owns otopi.plugins is where it belongs.

Comment 5 Alon Bar-Lev 2014-01-06 22:37:41 UTC
Ohad,
Please provide the set of channels required on rhel for vdsm to be installed.
Thanks,

Comment 6 Alon Bar-Lev 2014-01-07 08:36:03 UTC
Hi Anitha,
Can you please assist?
Thanks,

Comment 7 Anitha Udgiri 2014-01-07 17:35:09 UTC
Alon,
   The channels initially used to install the host should be good enough.
Just wondering if there were some issues with the packages in the channels when the user tried the install.
I see that this case is almost 6 months old. 
Does the problem still occur when following the installation steps mentioned here :
https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.2/html-single/Installation_Guide/index.html#Subscribing_to_Required_Channels_using_RHN_Classic  ?

Comment 9 Andreas Muehlemann 2014-01-13 08:06:59 UTC
Hi Anitha

Now the documentation in section 9.3.3 mentions the the channel

Red Hat Enterprise Virt Management Agent (v 6 x86_64)

which contains the vdsm package. This channel was missing when I tried the installation some month ago.

Thank you for correcting the documentation.

Best regards
Andreas

Comment 10 Ofer Schreiber 2014-01-26 14:51:35 UTC
Andreas, from you last comment I understand that this issue has been resolved for you, so I'm closing this bug.

If this isn't the case, please reopen it.


Note You need to log in before you can comment on or make changes to this bug.