Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981170 - ovirt node always use the first one of the disk list on boot_device_page as boot disk
Summary: ovirt node always use the first one of the disk list on boot_device_page as b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 965907 1150377
Blocks: 1063989 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-07-04 07:42 UTC by haiyang,dong
Modified: 2016-02-10 20:04 UTC (History)
18 users (show)

Fixed In Version: ovirt-node-3.0.1-18.el6_5.3
Doc Type: Bug Fix
Doc Text:
Clone Of: 965907
Environment:
Last Closed: 2015-02-11 20:46:01 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description haiyang,dong 2013-07-04 07:42:48 UTC
+++ This bug was initially created as a clone of Bug #965907 +++

Description of problem:
There two disks on local host(seen boot_device_page.png), select the second one of the disk list as the boot/HOSTVG disk,
but after install process finished, check that ovirt node still used the first one of the disk list on boot_device_pag as boot disk,
not the user selected disk(seen progress_page.png).
 

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-1.0.20130517.fc18.iso

How reproducible:
100%

Steps to Reproduce:

Actual result:
ovirt node always use the first one of the disk list on boot_device_pag as boot disk
          
                                                  
Expect result:
ovirt node should use the user selected disk as boot disk on boot_device_page

Additional info:

--- Additional comment from haiyang,dong on 2013-05-21 21:35:57 EDT ---

Comment 1 haiyang,dong 2013-07-04 07:46:28 UTC
Also can reproduce it in the follow rhev-h version
rhev-hypervisor6-6.5-20130222.0.auto1710.el6
ovirt-node-3.0.0-1.999.20130702120359git0015156.el6.noarch,

so need clone it from upstream bug Component to downstream Component in order to also track it in rhev-h

Comment 4 RHEL Product and Program Management 2013-10-14 03:13:20 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 haiyang,dong 2013-10-18 06:24:18 UTC
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

Now it could use the user selected disk as boot disk on boot_device_page.
so this bug has been fixed. I will verify it after the status changed from "MODIFIED" to "ON_QA".

Comment 6 haiyang,dong 2013-10-23 06:23:27 UTC
According to comment 5, Change the status into "VERIFIED".

Comment 9 Ying Cui 2014-02-12 12:05:47 UTC
This bug will be cloned to 6.5.z, and its flag is rhel-6.6.0, so change it back to 'ON_QA', we need to test it on rhevh6.6 build.

Comment 12 haiyang,dong 2014-11-12 11:03:15 UTC
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

Now it could use the user selected disk as boot disk on boot_device_page.
so this bug has been fixed in in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED"

Comment 14 errata-xmlrpc 2015-02-11 20:46:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.