Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981146 - pmchart in archive mode uses wrong (old) update interval when loading additional views
Summary: pmchart in archive mode uses wrong (old) update interval when loading additio...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pcp-gui
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mark Goodwin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-04 06:34 UTC by Mark Goodwin
Modified: 2014-02-04 21:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-04 21:43:12 UTC


Attachments (Terms of Use)
patch to add setArchiveInterval method to pmchart timecontrol and call it when a pmtime 'delta' packet is received (deleted)
2013-07-04 06:39 UTC, Mark Goodwin
no flags Details | Diff

Description Mark Goodwin 2013-07-04 06:34:20 UTC
Description of problem: in archive mode, pmchart "forgets" the current update interval after loading a second view - it falls back to the original default update interval from when pmchart was first started - but only for the new chart(s) - existing charts are still correct (but obviously inconsistent with the new charts because they are plotted with different update intervals!)

Version-Release number of selected component (if applicable):
pcp-gui-1.5.9-1.x86_64

How reproducible: always

Steps to Reproduce:
1. run pmchart -a somearchive -c CPU
2. expose the time controls and change the update interval
3. load some another view, say Loadavg

Actual results:
pmchart creates the second view, but with the original update interval that pmchart was first started with

Expected results:
pmchart should create the second view using the current update interval

Additional info:
fix available - I'll post it. This is similar to an earlier bug (now fixed) where pmchart forgets the archive position when loading a new view - the update interval is affected too,

Comment 1 Mark Goodwin 2013-07-04 06:39:39 UTC
Created attachment 768607 [details]
patch to add setArchiveInterval method to pmchart timecontrol and call it when a pmtime 'delta' packet is received

patch to save the new update interval when a pmtime 'delta' packet is received

Comment 2 Nathan Scott 2014-02-04 21:43:12 UTC
Closing out manually - issue has been long since fixed.


Note You need to log in before you can comment on or make changes to this bug.