Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 981097 - Disable “Use Bridge” failed after configure nic with "Bridge"
Summary: Disable “Use Bridge” failed after configure nic with "Bridge"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-04 02:51 UTC by haiyang,dong
Modified: 2014-01-21 19:43 UTC (History)
13 users (show)

Fixed In Version: ovirt-node-3.0.0-6.el6
Doc Type: Bug Fix
Doc Text:
Previously the bridged layout could be set in the NIC details dialog, but it couldn't be switched back to the direct (bridgeless) mode. Now the bridged mode can be turned on and off as expected.
Clone Of:
Environment:
Last Closed: 2014-01-21 19:43:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0033 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-22 00:14:30 UTC
oVirt gerrit 16514 None None None Never

Description haiyang,dong 2013-07-04 02:51:25 UTC
Description of problem:
Configure nic with "Birdge", after configure nic successfully, then wanted to disable "Use Bridge".
But it failed to disable “Use Bridge”

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1710.el6
ovirt-node-3.0.0-1.999.20130702120359git0015156.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.Enter NIC Details page to configure network
2.Select the item "() DHCP" of IPv4 Setting and the item "Use Bridge"
3.Then click "Save" button
4.After configure nic succcess. Press "F2" to drop into shell and
execute "ifconfig |more" to check whether configure nic using "bridge"
success or not
5.Then Disable “Use Bridge” and just select the item "() DHCP" of IPv4 Setting
to configure nic again

Actual results:
After step 5,Disable “Use Bridge” failed, still using "bridge" for that nic


Expected results:
After step 5,Disable “Use Bridge” success, using "bridgeless" for that nic

Additional info:

Comment 2 Fabian Deutsch 2013-07-05 14:08:53 UTC
Fixed in http://gerrit.ovirt.org/16514

Tested as follows:
1. UI with patch
2. Enter NIC details dialog
3. Configure NIC with dhcp and bridge
4. Check on console using ip l that the bridge is used (or that the bridged layout is used in /etc/default/ovirt)
5. Re-enter setup and NIC details dialog
6. Configure NIC with dhcp and _no_ bridge
7. Check on the console that no bridge is present (or that no layout is given in /etc/default/ovirt)

Comment 4 haiyang,dong 2013-08-01 10:32:55 UTC
Test version:
rhev-hypervisor6-6.5-20130725.0.el6 
ovirt-node-3.0.0-6.1.el6

Tested as follows:
1. Clean install rhev-hypervisor6-6.5-20130725.0.el6 
2. Enter NIC details dialog
3. Configure NIC with dhcp and bridge
4. Check on console using ip l that the bridge is used (or that the bridged layout is used in /etc/default/ovirt)
5. Re-enter setup and NIC details dialog
6. Configure NIC with dhcp and _no_ bridge
7. Check on the console that no bridge is present (or that no layout is given in /etc/default/ovirt)

so this bug has been fixed, change the status into "VERIFIED"

Comment 8 Cheryn Tan 2013-11-08 00:33:13 UTC
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 10 errata-xmlrpc 2014-01-21 19:43:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html


Note You need to log in before you can comment on or make changes to this bug.