Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980948 - CLI - "system packages --install" shows RequestTimeout error.
Summary: CLI - "system packages --install" shows RequestTimeout error.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: Nightly
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: 970720
TreeView+ depends on / blocked
 
Reported: 2013-07-03 15:54 UTC by Hayk Hovsepyan
Modified: 2014-07-02 14:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:08:07 UTC
Target Upstream Version:
mmccune: needinfo+


Attachments (Terms of Use)

Description Hayk Hovsepyan 2013-07-03 15:54:14 UTC
Description of problem:
Remote installing some package on client system shows error: "Remote action failed:RequestTimeout:"

Version-Release number of selected component (if applicable):
Katello-Katello-Installation-ConfigureRepos-1.7-3.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-glue-pulp-1.4.2-1.git.761.9817788.el6.noarch
katello-1.4.2-1.git.761.9817788.el6.noarch
candlepin-tomcat6-0.8.15-1.el6.noarch
ruby193-rubygem-net-ldap-0.3.1-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
openldap-2.4.23-26.el6.x86_64
signo-0.0.9-1.el6.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
Katello-Katello-Installation-KatelloNightly-1.0-13.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
candlepin-cert-consumer-cfseserver4.usersys.redhat.com-1.0-1.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.98.3567fd4.el6.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-configure-1.4.3-1.git.65.63e692c.el6.noarch
pulp-server-2.1.2-0.3.beta.el6.noarch
candlepin-selinux-0.8.15-1.el6.noarch
elasticsearch-0.19.9-7.el6.noarch
katello-common-1.4.2-1.git.761.9817788.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.761.9817788.el6.noarch
katello-glue-candlepin-1.4.2-1.git.761.9817788.el6.noarch
katello-all-1.4.2-1.git.761.9817788.el6.noarch
katello-repos-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.98.3567fd4.el6.noarch
pulp-rpm-plugins-2.1.2-0.3.beta.el6.noarch
candlepin-0.8.15-1.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
Katello-Katello-Configuration-KatelloClient-1.1-49.noarch
pulp-selinux-2.1.2-0.3.beta.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Create custom repo (zoo) and sync it.
2. Create content definition, add repo, publish and promote to "dev" environment.
3. Create activation key, add content view and resource pool into it, register a client by activation key.
4. Try to remote install some package from zoo repo to client system by CLI: "system packages --install "lion" --org "$org" --name "$system"". You will see the error.

Actual results:
"Remote action failed:RequestTimeout:" is shown while remote installing package on system.

Expected results:
install should finish successfully

Additional info:
on the same client system local run "yum install -y lion" works fine

Comment 1 RHEL Product and Program Management 2013-09-17 04:24:21 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Mike McCune 2013-10-10 04:18:57 UTC
are you sure you had katello-agent working properly before trying the CLI command?

it will always time out if katello-agent isn't installed and connected up to the server.

removing 6.0.2 flag until this is clarified.

Comment 5 RHEL Product and Program Management 2013-10-10 04:35:05 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 Hayk Hovsepyan 2013-10-10 09:59:25 UTC
katello-agent is properly configured on client and connected to server.
Now remote package install shows error: "error: sequence item 0: expected string, list found (more in the log file /var/log/katello/client.log)"
But "yum install -y lion" local install works fine.

Comment 7 Brad Buckingham 2013-10-14 19:56:39 UTC
I ran through the scenario above on the latest snapshot and a pkg install works successfully for me.  We may need to debug to see what is different between configurations.

Server:
katello-1.4.6-31.el6sat.noarch

Client:
katello-agent-1.4.4-3.el6sat.noarch
Red Hat Enterprise Linux Server release 6.4 (Santiago)

CLI command from server:
katello> system packages --install "lion" --org ACME_Corporation --name dhcp-8-30-108.lab.eng.rdu2.redhat.com
Performing remote action [ d1bd782c-a547-487d-86e6-a06b92e0b767 ]... 
Remote action finished:lion-0.4-1.noarch

agent.log on client during the command execution:
2013-10-14 15:48:51,140 [INFO][worker-0] sendreply() @ rmi.py:172 - 763b64b4-2fb6-4ead-bf0c-7db7144d061f processed in: 2.241 (seconds)

query on the client after execution:
# rpm -q lion
lion-0.4-1.noarch

iptables is off and selinux is permissive.

Comment 8 Hayk Hovsepyan 2013-10-15 11:53:23 UTC
Thanks Brad, it was misconfiguration of my client.

Verified on revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-1.3.0-17.el6sat.noarch
katello-cli-1.4.3-20.el6sat.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-candlepin-1.4.6-31.el6sat.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
candlepin-cert-consumer-poseidon.usersys.redhat.com-1.0-1.noarch
katello-repos-1.5.1-1.el6.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-12.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
signo-0.0.22-2.el6sat.noarch
foreman-proxy-1.3.0-3.el6sat.noarch
foreman-postgresql-1.3.0-17.el6sat.noarch
katello-cli-common-1.4.3-20.el6sat.noarch
katello-configure-1.4.7-3.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
signo-katello-0.0.22-2.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-glue-elasticsearch-1.4.6-31.el6sat.noarch
katello-1.4.6-31.el6sat.noarch
katello-configure-foreman-1.4.7-3.el6sat.noarch
katello-all-1.4.6-31.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
katello-agent-1.4.4-3.el6sat.noarch
Katello-Katello-Installation-HammerCLI-1.0-8.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
katello-configure-foreman-proxy-1.4.7-3.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-0.8.25-1.el6sam.noarch
katello-common-1.4.6-31.el6sat.noarch
katello-glue-pulp-1.4.6-31.el6sat.noarch
katello-foreman-all-1.4.6-31.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch

Comment 9 Bryan Kearney 2014-07-02 14:08:07 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.