Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 98092 - changing timezone after installation causes "Date & Time" GUI to fail
Summary: changing timezone after installation causes "Date & Time" GUI to fail
Keywords:
Status: CLOSED DUPLICATE of bug 76313
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-26 15:02 UTC by Need Real Name
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:56:51 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-06-26 15:02:15 UTC
Description of problem: Changing the timezone after initial system installation
causes redhat-config-date to fail with a python error (which also means the
"Date & Time" GUI from the system menu  will no longer come up).


Version-Release number of selected component (if applicable): RH 8.0


How reproducible:  Every time


Steps to Reproduce:
1.Bring up GUI:   System Settings -> Date & Time  to verify that it comes up
successfully.
2.Use the command line to bring up the same gui to verify that it comes up
correctly:   
root>  redhat-config-date

*** Note that not all continents are shown in the GUI (Japan, GMT, etc.) which
means they are not available for selection by the user.

3.Change the timezone to GMT manually by:  
    root>  timeconfig Etc/GMT
   (We would not have done this manually if GMT showed up in the "Date & Time" GUI.)
4. Reboot the system to see that the timezone is now showing GMT.
5. Bring up the GUI:  System Settings -> Date & Time.  
Nothing will happen becuase the GUI will never come up (it has actually crashed)
6. Use the command line to bring up the GUI and see the actual python error: 
root> redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'

    
Actual results:


Expected results:


Additional info:  
You can use redhat-config-time instead of redhat-config-date and see the same
results.  

This bug exists on systems that have the latest redhat network patches as well
as systems created several months back.

Initially, our machines were installed with timezone set to "America/New_York".
 When I brought up the "Date & Time" GUI, selections for GMT and other
continents (like Japan) are not available for selection.  When you look at the
"Date & Time" code, please ensure that it displays all continent timezones that
are in the timezone directory and its subdirectories. (These subdirectories were
available during installation, but were not available through the "Date & Time"
GUI after installation.)

Comment 1 Need Real Name 2003-06-26 15:08:49 UTC
redhat-config-date-1.5.2-10

Comment 2 Need Real Name 2003-06-26 15:17:45 UTC
Note:  After seeing the python error, you change the timezone back to the
original installation timezone and the "Date & Time" GUI will again be displayed.
root>  timeconfig America/New_York
root> redhat-config-date
         (the "Date & Time GUI will successfully display again)


Comment 3 Brent Fox 2003-06-26 15:22:07 UTC

*** This bug has been marked as a duplicate of 76313 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:56:51 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.