Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980748 - The output of "subscription-manager attach --auto" is wrong!
Summary: The output of "subscription-manager attach --auto" is wrong!
Keywords:
Status: CLOSED DUPLICATE of bug 977321
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager
Version: 5.10
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel510
TreeView+ depends on / blocked
 
Reported: 2013-07-03 07:36 UTC by xingge
Modified: 2016-09-20 02:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-03 13:38:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description xingge 2013-07-03 07:36:49 UTC
Description of problem:
The output of "subscription-manager attach --auto" is wrong!

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.8.11-1.el5
subscription-manager-firstboot-1.8.11-1.el5
subscription-manager-1.8.11-1.el5
python-rhsm-1.8.12-1.el5

How reproducible:
Always

Steps to Reproduce:
1.register the system 
#subscription-manager register 
Username:stage_test_12
Password:

2.Auto subscribe
#subscription-manager attach --auto
Installed Product Current Status:
Product Name: 	Red Hat Enterprise Linux Server
Status:			Not Subscribed

3 list consumed subscription
#subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to 4 guests)
Provides:          Red Hat Software Collections Beta (for RHEL Server)
                   Red Hat Enterprise Linux Server
                   Red Hat Beta
SKU:               RH0103708
Contract:          10014723
Account:           5206751
Serial:            6906917654128083902
Pool ID:           8a99f9843c01ccba013c037bb23e0259
Active:            True
Quantity Used:     1
Service Level:     Premium
Service Type:      L1-L3
Status Details:    
Starts:            12/31/2012
Ends:              12/31/2013

Actual results:
The output said the system is not subscribe, but look at step3 we know that
actually the system is "Sbuscribed".

Expected results:
The output should be:
Installed Product Current Status:
Product Name: 	Red Hat Enterprise Linux Server
Status:         Subscribed

Additional info:

Comment 1 RHEL Product and Program Management 2013-07-03 07:38:09 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 2 xingge 2013-07-03 08:06:55 UTC
When run the "subscription-manager attach --auto" again after run "subscription-manager attach --auto", the output become correct like below:
#subscription-manager attach --auto
Installed Product Current Status:
Product Name: 	Red Hat Enterprise Linux Server
Status:			Not Subscribed
#subscription-manager attach --auto
All installed products are covered by valid entitlements. No need to update subscriptions at this time.
Installed Product Current Status:
Product Name: 	Red Hat Enterprise Linux Server
Status:	        Subscribed

Comment 3 RHEL Product and Program Management 2013-07-03 08:08:26 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 4 John Sefler 2013-07-03 13:35:21 UTC
likely a duplicate of bug 977321
possibly a duplicate of bug 964332

Comment 5 Carter Kozak 2013-07-03 13:38:22 UTC
Duplicate of BZ977321

*** This bug has been marked as a duplicate of bug 977321 ***


Note You need to log in before you can comment on or make changes to this bug.