Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980725 - Dist-geo-rep : 'gluster volume geo status' is not showing status of sessions which are in 'Not started' or 'Stopped' state
Summary: Dist-geo-rep : 'gluster volume geo status' is not showing status of sessions...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: 2.1
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: ---
Assignee: Avra Sengupta
QA Contact: amainkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-03 06:53 UTC by Rachana Patel
Modified: 2015-04-20 11:57 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.4.0.12rhs.beta4_1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-23 22:38:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rachana Patel 2013-07-03 06:53:24 UTC
Description of problem:
Distributed-geo-rep : 'gluster volume geo session' is not showing  status of sessions which are in 'Not started' or 'Stopped' state

Version-Release number of selected component (if applicable):
3.4.0.12rhs.beta1-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:

1. Create multiple geo rep sessions between master and slave cluster
2. Keep changing status of session ('not started', 'stopped' etc) and check status using 'gluster volume geo status' and 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> status.

[root@hulk ~]# gluster volume geo master2 10.70.43.147::slave2 status
NODE                        MASTER     SLAVE                   HEALTH         UPTIME       
-------------------------------------------------------------------------------------------
wall.blr.redhat.com         master2    10.70.43.147::slave2    Not Started    N/A          
ironman.blr.redhat.com      master2    10.70.43.147::slave2    Not Started    N/A          
lannister.blr.redhat.com    master2    10.70.43.147::slave2    Not Started    N/A       
   
[root@hulk ~]# gluster volume geo status
NODE                        MASTER     SLAVE                         HEALTH    UPTIME       
--------------------------------------------------------------------------------------------
ironman.blr.redhat.com      master1    ssh://10.70.43.147::slave1    Stable    00:07:51     
wall.blr.redhat.com         master1    ssh://10.70.43.147::slave1    Stable    00:07:52     
lannister.blr.redhat.com    master1    ssh://10.70.43.147::slave1    Stable    00:07:52     


       
[root@hulk ~]# gluster volume geo master2 10.70.43.147::slave2 stop
Stopping geo-replication session between master2 & 10.70.43.147::slave2 has been successful
[root@hulk ~]# gluster volume geo master2 10.70.43.147::slave2 status
NODE                        MASTER     SLAVE                   HEALTH     UPTIME       
---------------------------------------------------------------------------------------
ironman.blr.redhat.com      master2    10.70.43.147::slave2    Stopped    N/A          
wall.blr.redhat.com         master2    10.70.43.147::slave2    Stopped    N/A          
lannister.blr.redhat.com    master2    10.70.43.147::slave2    Stopped    N/A          
[root@hulk ~]# gluster volume geo status
NODE                        MASTER     SLAVE                         HEALTH    UPTIME       
--------------------------------------------------------------------------------------------
lannister.blr.redhat.com    master1    ssh://10.70.43.147::slave1    Stable    00:08:35     
ironman.blr.redhat.com      master1    ssh://10.70.43.147::slave1    Stable    00:08:34     
wall.blr.redhat.com         master1    ssh://10.70.43.147::slave1    Stable    00:08:34   





Actual results:
 'gluster volume geo session' is not showing  status of sessions which are in 'Not started' or 'Stopped' state

Expected results:
It should show all session information

Additional info:

Comment 2 M S Vishwanath Bhat 2013-08-07 10:59:20 UTC
Now geo-replication status shows all the session's status. But it's not ordered properly.

Technically speaking the status shown is correct. But it's not ordered properly. For a user it would be good to see 'session' wise. Like in the status lines of one session should be together. Similar to volume status.

Is that achievable? Or this is just fine? Or should I close this bug and open other for ordering them properly?

[root@pythagoras ]# gluster v geo master status
 
NODE                         MASTER    SLAVE                    HEALTH             UPTIME   
--------------------------------------------------------------------------------------------
pythagoras.blr.redhat.com    master    ssh://neumann::slave3    Initializing...    N/A      
pythagoras.blr.redhat.com    master    ssh://riemann::slave2    Not Started        N/A      
pythagoras.blr.redhat.com    master    ssh://euclid::slave1     Stopped            N/A      
ramanujan.blr.redhat.com     master    ssh://neumann::slave3    Initializing...    N/A      
ramanujan.blr.redhat.com     master    ssh://riemann::slave2    Not Started        N/A      
ramanujan.blr.redhat.com     master    ssh://euclid::slave1     Stopped            N/A      
[root@pythagoras ]# gluster v geo master status
 
NODE                         MASTER    SLAVE                    HEALTH         UPTIME     
------------------------------------------------------------------------------------------
pythagoras.blr.redhat.com    master    ssh://neumann::slave3    Stable         00:01:40   
pythagoras.blr.redhat.com    master    ssh://riemann::slave2    Not Started    N/A        
pythagoras.blr.redhat.com    master    ssh://euclid::slave1     Stopped        N/A        
ramanujan.blr.redhat.com     master    ssh://neumann::slave3    Stable         00:01:41   
ramanujan.blr.redhat.com     master    ssh://riemann::slave2    Not Started    N/A        
ramanujan.blr.redhat.com     master    ssh://euclid::slave1     Stopped        N/A

Comment 3 M S Vishwanath Bhat 2013-08-07 11:25:13 UTC
Amar, Avra,

The status shown is technically correct. But the ordering is not user friendly. Ideally I would expect it to be ordered session wise, just like volume status (where it is volume wise)

Should I move this bug to verify and open another bug for proper ordering? Or that should be fixed as part of this bug itself?

Comment 4 Amar Tumballi 2013-08-07 11:41:15 UTC
MSV, If you think *technical* issues reported initial bug report is fixed, please mark the bug VERIFIED. You should be opening a new bug IMO.

Comment 5 M S Vishwanath Bhat 2013-08-07 11:53:38 UTC
Just found, there is already another bug opened for that. https://bugzilla.redhat.com/show_bug.cgi?id=988722

So closing this bug as VERIFIED.

Comment 6 Scott Haines 2013-09-23 22:38:42 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Comment 7 Scott Haines 2013-09-23 22:41:28 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html


Note You need to log in before you can comment on or make changes to this bug.