Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980705 - Wrong option mark is used for the help content of "rhc cartridge add"
Summary: Wrong option mark is used for the help content of "rhc cartridge add"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface
Version: 2.x
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Clayton Coleman
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-03 05:16 UTC by Qiushui Zhang
Modified: 2015-05-15 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-09 05:09:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qiushui Zhang 2013-07-03 05:16:54 UTC
Description of problem:
In the help of "rhc cartridge add", "[]" is used for "--app NAME", which is a REQUIRED option. It should be "<>".

Version-Release number of selected component (if applicable):
rhc 1.11.2

How reproducible:
Always

Steps to Reproduce:
1.Type "rhc cartridge add --help"
2.Check the help content. 


Actual results:
"[--app NAME]" is shown. While this is a REQUIRED option.

Expected results:
"< >" should be used.

Additional info:
This issue also happens to other "rhc cartridge" options, e.g. remove, show, start, etc.

Comment 1 Clayton Coleman 2013-07-09 05:09:17 UTC
It's optional today because if you are in the git repository for the app, app name and domain name are read from the git repository.


Note You need to log in before you can comment on or make changes to this bug.