Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980592 - SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/jre/bin/java from 'write' accesses on the directory publish.
Summary: SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/jre/bin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freeipa
Version: 19
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Rob Crittenden
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-02 19:41 UTC by Dean Hunter
Modified: 2013-07-08 13:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-08 13:19:37 UTC


Attachments (Terms of Use)

Description Dean Hunter 2013-07-02 19:41:05 UTC
Description of problem:

An SELinux alert is being raised during ipa-server-install: 

SELinux is preventing /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/jre/bin/java from 'write' accesses on the directory publish. 

I am using selinux-policy from updates-testing to resolve bug #976159.


Version-Release number of selected component (if applicable):

freeipa-server-3.2.1-1.fc19.x86_64
selinux-policy-3.12.1-57.fc19.x86_64


How reproducible: Consistent


Steps to Reproduce:
1. Build a new Fedora 19 VM
2. yum update --assumeyes
3. yum update --assumeyes --enablerepo updates-testing selinux-policy
4. yum install --assumeyes bind bind-dyndb-ldap freeipa-server
5. ipa-server-install ....


Actual results:

The server appears to install successfully, but there is an SELinux alert.


Expected results:

Successful server install without any alerts


Additional info:

I have reported bug #980588 on selinux-policy.  I need to understand the impact of this alert on the IPA server.

Comment 1 Dean Hunter 2013-07-08 13:19:37 UTC
The problem is resolved with selinux-policy-3.12.1-59.fc19.noarch.


Note You need to log in before you can comment on or make changes to this bug.