Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980589 - ABRT configuration options does not work as expected.
Summary: ABRT configuration options does not work as expected.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 560
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Matej Kollar
URL:
Whiteboard:
Depends On:
Blocks: sat560-abrt
TreeView+ depends on / blocked
 
Reported: 2013-07-02 19:22 UTC by Dimitar Yordanov
Modified: 2013-10-01 21:26 UTC (History)
4 users (show)

Fixed In Version: spacewalk-backend-2.0.3-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-01 21:26:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dimitar Yordanov 2013-07-02 19:22:43 UTC
Description of problem:

ABRT options "Enable Software Crash Reporting" and "Enable Upload Of Crash Files " have no impact on the feature functionality.


Version-Release number of selected component (if applicable):
Satellite-5.6.0-RHEL6-re20130626.1

How reproducible:
100%

Steps to Reproduce:
1. Register system to Satellite.
2. Admin -> Organization -> Red Hat SatTeam -> Configuration
3  Uncheck "Enable Software Crash Reporting" -> Press Update Organization
4. spacewalk-abrt --sync
 
Actual results:
All available Software Crashes are pushed to Satellite.

import sys, xmlrpclib, re, getopt
RHN_SERVER='https://xxxx/rpc/api'
RHN_USER='xx'
RHN_PASS='xx'

client = xmlrpclib.Server(RHN_SERVER, verbose=0)
key = client.auth.login(RHN_USER, RHN_PASS)

client.org.isCrashReportingEnabled(key, 1)
False

bash# spacewalk-abrt --sync

client.system.crash.listSystemCrashes(key,1000010006)

[{'count': 1, 'username': '', 'executable': '/bin/sleep', 'crash': 'ccpp-2013-07-02-09:59:31-4627', 'uuid': '', 'created': <DateTime '20130702T14:36:12' at 7f1a13e12b90>, 'kernel': '2.6.32-358.el6.x86_64', 'component': '', 'modified': <DateTime '20130702T14:36:14' at 7f1a13e12bd8>, 'analyzer': 'CCpp', 'cmdline': 'sleep 100', 'reason': 'Process /bin/sleep was killed by signal 11 (SIGSEGV)', 'architecture': 'x86_64', 'path': '/var/spool/abrt/ccpp-2013-07-02-09:59:31-4627', 'id': 73}, {'count': 1, 'username': '',

Expected results:
The behaviour should be the same as in Spacewalk.

#spacewalk-abrt --sync
An error has occurred:
Error communicating with server. The message was:

Error Class Code: 5006
Error Class Info: Crash reporting is disabled for this organization
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

See /var/log/up2date for more information


Additional info:
Manipulating with ABRT configuration option "Enable Upload Of Crash Files" has no effect as well. The Crash files are uploaded to the Satellite. On Spacewalk works as expected.

Comment 4 Clifford Perry 2013-10-01 21:26:40 UTC
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html


Note You need to log in before you can comment on or make changes to this bug.