Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980482 - Downloaded CSV file of "Advanced Search" has got always empty fields
Summary: Downloaded CSV file of "Advanced Search" has got always empty fields
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Depends On:
Blocks: sat560-blockers 1154707
TreeView+ depends on / blocked
 
Reported: 2013-07-02 14:01 UTC by Martin Korbel
Modified: 2014-10-20 15:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1154707 (view as bug list)
Environment:
Last Closed: 2013-10-01 21:51:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Korbel 2013-07-02 14:01:05 UTC
Description of problem:
I have detected the problem in this CSV file (export of "Advanced Search").
I have got always empty fields "Matching Field Name" and "Matching Field Value" in downloaded CSV file.

Version-Release number of selected component (if applicable):
Sat560
Sat550

How reproducible:
always

Steps to Reproduce:
1. We have got satellite with some clients.
2. go to System > Advanced Search
3. Change value of "Field to Search" field (ex. IP Address)
4. fill something into "Search For" field and click "Search"
5. click on the link "Download CSV" and download the CVS file.
6. we get something as this
download.csv
----------------------------------------
Id,System,Matching Field Name,Matching Field Value,Entitlement Level
1000010010,test02-64.sysmgmt.lab.eng.rdu2.redhat.com,,,Management
1000010018,test02-64.sysmgmt.lab.eng.rdu2.redhat.com,,,Management
1000010015,test02-64.sysmgmt.lab.eng.rdu2.redhat.com,,,"Management, Provisioning"


Actual results:
Fields "Matching Field Name" and "Matching Field Value" are always empty.

Expected results:
Fields "Matching Field Name" and "Matching Field Value" will not be empty.

Additional info:
This is regression against Sat541. Here it works correctly.
download.csv
----------------------------------------
Id,System,Matching Field Name,Matching Field Value,Entitlement Level
1000010115,IP-10.1.1.100.redhat.com,ipaddr,10.1.1.100,Management
1000010116,IP-10.1.1.101.redhat.com,ipaddr,10.1.1.101,Management
1000010125,IP-10.1.1.110.redhat.com,ipaddr,10.1.1.110,Management
1000010025,IP-10.1.1.10.redhat.com,ipaddr,10.1.1.10,Management

Comment 1 Tomáš Kašpárek 2013-07-15 09:18:45 UTC
fixed in spacewalk.git: 281f99ba270eecfc28bc32d710b9f5fef6cb131c

Comment 5 Clifford Perry 2013-10-01 21:51:34 UTC
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html


Note You need to log in before you can comment on or make changes to this bug.