Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980478 - RHEV-H upgrade via RHEV-M fails multiple times before completing successfully
Summary: RHEV-H upgrade via RHEV-M fails multiple times before completing successfully
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.5
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-02 13:56 UTC by Idith Tal-Kohen
Modified: 2013-11-28 00:08 UTC (History)
13 users (show)

Fixed In Version: ovirt-node-2.5.0-17.el6_4.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-16 15:29:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1077 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2013-07-16 19:29:13 UTC

Description Idith Tal-Kohen 2013-07-02 13:56:25 UTC
This bug has been copied from bug #958279 and has been proposed
to be backported to 6.4 z-stream (EUS).

Comment 4 cshao 2013-07-09 05:11:00 UTC
I still can reproduce the failure. After the machine comes backup it's still listed as failed. if I clicked approve, it came back up and all is well.

Test Version:
rhev-hypervisor6-6.4-20130705.0.el6_4
ovirt-node-2.5.0-17.el6_4.7.noarch
Dell 790 + Intel CPU
RHEV-M Si29.2
Compatibility version: 3.0
Upgrade RHEV-H 6.3-20121012 to 6.4-20130705.

So change bug status to ASSIGNED.

Comment 5 Mike Burns 2013-07-09 11:52:08 UTC
The failure mentioned here is a false failure which is CANTFIX due to the way RHEV-M initiated upgrades work in 6.3 (fixed by simply setting host to maintenance and re-activating).  This bug refers to intermittent real failures where upgrades would fail sometimes and not others.

Comment 6 cshao 2013-07-10 08:27:48 UTC
Test Version:
rhev-hypervisor6-6.4-20130709.0.el6_4
ovirt-node-2.5.0-17.el6_4.8.noarch
RHEV-M Si29.2 (Compatibility version: 3.0)

Dell 790 + Intel CPU

Test steps:
1. Upgrade RHEV-H 6.3-20121012 to 6.4-20130709, due to bug 920671(won't fixed), there is a failure but it can up by workaround (simply setting host to maintenance and re-activating)
2. Upgrade RHEV-H 6.4-20130709 to 6.4-2013-0318 can successful.
3. Upgrade RHEV-H 6.4-20130318 to 6.4-2013-0705 can successful.
4. Upgrade RHEV-H 6.4-20130705 to 6.4-2013-0709 can successful.

So the bug was fixed, change bug status to VERIFIED.

Comment 8 errata-xmlrpc 2013-07-16 15:29:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1077.html


Note You need to log in before you can comment on or make changes to this bug.