Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980473 - nsswitch.conf not restored back after IPA server un-install
Summary: nsswitch.conf not restored back after IPA server un-install
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kosek
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-02 13:47 UTC by Kaleem
Modified: 2013-07-03 11:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-03 11:33:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
output of each step (deleted)
2013-07-02 13:47 UTC, Kaleem
no flags Details

Description Kaleem 2013-07-02 13:47:10 UTC
Created attachment 767728 [details]
output of each step

Description of problem:
/etc/nsswitch.conf contents is not restored back after IPA Server un-install.

Version-Release number of selected component (if applicable):
[root@rhel70-ipa-master ~]# rpm -q ipa-server
ipa-server-3.2.1-1.el7.x86_64
[root@rhel70-ipa-master ~]#

How reproducible:
Always

Steps to Reproduce:
1.Check nsswitch.conf content and install IPA Server
2.Check nsswitch.conf content after IPA Server install
3.Un-install IPA Server and check nsswitch.conf content.

Actual results:
nsswitch.conf content is not restored after IPA Server un-install.

Expected results:
nsswitch.conf content should be restored after IPA Server un-install.

Additional info:
(1)Please refer attached file for output of steps mentioned above.

Comment 2 Alexander Bokovoy 2013-07-03 11:08:20 UTC
We have asked to explicitly not remove 'sss' from nsswitch.conf because 'sss' in nsswitch.conf should be by default in all installs starting from Fedora 18. See https://bugzilla.redhat.com/show_bug.cgi?id=867473 for more details.

If you have nsswitch.conf without sss by default in fresh installs, this is probably a bug. If you have that from an older VM, then please update your VM.

Comment 3 Kaleem 2013-07-03 11:23:32 UTC
Ok. got it.

But nss does not exits in nsswitch.conf by default on fresh installs. so cloning https://bugzilla.redhat.com/show_bug.cgi?id=867473 for RHEL 7.0.

We can close this as not a bug.


Note You need to log in before you can comment on or make changes to this bug.