Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 980212 - doesn't boot on beagle-xm without first running clist (and klist)
Summary: doesn't boot on beagle-xm without first running clist (and klist)
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: arm-boot-config
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brendan Conoboy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-01 17:55 UTC by Kaleb KEITHLEY
Modified: 2015-02-18 11:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-18 11:18:00 UTC


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2013-07-01 17:55:46 UTC
Description of problem:

Filing at the request of dgilmore.

Installed f19 image dated 27 June from http://dl.fedoraproject.corg/pub/fedora-secondary/releases/19/images/armhfp/Fedora-Minimal/VFAT-armhfp-19-1-sda.raw.xz

Wrote the image to SD card and copied files per https://fedoraproject.org/wiki/Architectures/ARM/F19/Installation, s/panda/beagle/ as needed.

Added bootdir=/boot to uEnv.txt per dgilmore.

Machine would not boot. dgilmore suggested 'run clist' and 'run c14'.  I did that tried to boot and got:
  ** File not found /boot/vmlinuz- **
  ** File not found /boot/uInitrd- **
  ...

I next tried 'run klist' and 'run k1' at which point it did boot and ran until the known issue kernel oops.



Version-Release number of selected component (if applicable):

f19, kernel 3.9.5-301


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

boot without running cXX and kX


Additional info:

printenv dump as requested

U-Boot SPL 2013.04 (Jun 17 2013 - 12:38:17)                                     
OMAP SD/MMC: 0                                                                  
reading u-boot.img                                                              
reading u-boot.img                                                              
                                                                                
                                                                                
U-Boot 2013.04 (Jun 17 2013 - 12:38:17)                                         
                                                                                
OMAP3630/3730-GP ES1.2, CPU-OPP2, L3-165MHz, Max CPU Clock 1 Ghz                
OMAP3 Beagle board + LPDDR/NAND                                                 
I2C:   ready                                                                    
DRAM:  512 MiB                                                                  
NAND:  0 MiB                                                                    
MMC:   OMAP SD/MMC: 0                                                           
*** Warning - readenv() failed, using default environment                       
                                                                                
In:    serial                                                                   
Out:   serial                                                                   
Err:   serial                                                                   
Beagle xM Rev C                                                                 
No EEPROM on expansion board                                                    
Die ID #669400029ff80000015f26ad0f01d012                                        
musb-hdrc: ConfigData=0xde (UTMI-8, dyn FIFOs, bulk combine, bulk split, HB-ISO)
musb-hdrc: MHDRC RTL version 1.800                                              
musb-hdrc: setup fifo_mode 4                                                    
musb-hdrc: 28/31 max ep, 16384/16384 memory                                     
USB Peripheral mode controller at 480ab000 using PIO, IRQ 0                     
Net:   usb_ether                                                                
Hit any key to stop autoboot:  0                                                
OMAP3 beagleboard.org # printenv                                                
baudrate=115200                                                                 
beaglerev=xMC                                                                   
bootcmd=mmc dev ${mmcdev}; if mmc rescan; then if run userbutton; then setenv b;
bootdelay=3                                                                     
bootenv=uEnv.txt                                                                
bootfile=uImage.beagle                                                          
buddy=none                                                                      
camera=none                                                                     
console=ttyO2,115200n8                                                          
defaultdisplay=dvi                                                              
dieid#=669400029ff80000015f26ad0f01d012                                         
dvimode=640x480MR-16@60                                                         
ethact=usb_ether                                                                
importbootenv=echo Importing environment from mmc ...; env import -t $loadaddr e
loadaddr=0x80200000                                                             
loadbootenv=fatload mmc ${mmcdev} ${loadaddr} ${bootenv}                        
loadramdisk=fatload mmc ${mmcdev} ${rdaddr} ramdisk.gz                          
loaduimage=ext2load mmc ${mmcdev}:2 ${loadaddr} /boot/uImage                    
loaduimagefat=fatload mmc ${mmcdev} ${loadaddr} uImage                          
mmcargs=setenv bootargs console=${console} ${optargs} mpurate=${mpurate} buddy=}
mmcboot=echo Booting from mmc ...; run mmcargs; bootm ${loadaddr}               
mmcdev=0                                                                        
mmcroot=/dev/mmcblk0p2 rw                                                       
mmcrootfstype=ext3 rootwait                                                     
mpurate=auto                                                                    
nandargs=setenv bootargs console=${console} ${optargs} mpurate=${mpurate} buddy}
nandboot=echo Booting from nand ...; run nandargs; nand read ${loadaddr} 280000}
nandroot=ubi0:rootfs ubi.mtd=4                                                  
nandrootfstype=ubifs                                                            
ramargs=setenv bootargs console=${console} ${optargs} mpurate=${mpurate} buddy=}
ramboot=echo Booting from ramdisk ...; run ramargs; bootm ${loadaddr}           
ramroot=/dev/ram0 rw ramdisk_size=65536 initrd=0x81000000,64M                   
ramrootfstype=ext2                                                              
rdaddr=0x81000000                                                               
stderr=serial                                                                   
stdin=serial                                                                    
stdout=serial                                                                   
usbtty=cdc_acm                                                                  
userbutton=if gpio input 173; then run userbutton_xm; else run userbutton_nonxm;
userbutton_nonxm=gpio input 7;                                                  
userbutton_xm=gpio input 4;                                                     
vram=12M                                                                        
                                                                                
Environment size: 2359/131068 bytes                                             
OMAP3 beagleboard.org #

Comment 1 Brendan Conoboy 2013-07-01 19:18:41 UTC
Confirmed bug.  Config_omap3 doesn't set u_dtb, so abc thinks it didn't autodetect anything, even when it did.  Will be fixed in 0.57.

Comment 2 Brendan Conoboy 2013-07-01 21:01:33 UTC
Please try the scratch build from this URL:

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1950346

I don't have a beagle board to test with.

Comment 3 Fedora End Of Life 2015-01-09 22:39:34 UTC
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Fedora End Of Life 2015-02-18 11:18:00 UTC
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.