Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 97751 - /etc/rc.d/init.d/pcmcia contains invalid modprobe syntax
Summary: /etc/rc.d/init.d/pcmcia contains invalid modprobe syntax
Keywords:
Status: CLOSED DUPLICATE of bug 88054
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-20 09:41 UTC by Gary Oliver
Modified: 2006-02-21 18:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:56:48 UTC


Attachments (Terms of Use)

Description Gary Oliver 2003-06-20 09:41:35 UTC
/etc/rc.d/init.d/pcmcia contains invalid calls to modprobe when
the modules are located in a "preferred" category ('PC' var set.)



Version-Release number of selected component (if applicable):
At least 9  - don't know about previous versions

How reproducible:
I installed a "non-standard" kernel which placed modules in the
/lib/modules/<version>/kernel/drivers/pcmcia directory.  This caused
modprobe to be called with the "<modulename>.o" form (modprobe must
*not* have the trailing ".o" according to the man pages - and indeed
it will disallow the module name if present.

Steps to Reproduce:
See above.
    
Actual results:
See above.


Expected results:
-na-

Additional info:
Remove the ".o" from the calls to modprobe on lines 107, 108 and 109.

Comment 1 Bill Nottingham 2004-09-08 06:54:58 UTC

*** This bug has been marked as a duplicate of 88054 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:56:48 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.