Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 977091 - [RESTAPI] Template's timezone property should be accessible in API
Summary: [RESTAPI] Template's timezone property should be accessible in API
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Juan Hernández
QA Contact: Pavel Novotny
URL:
Whiteboard: virt
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-06-23 13:07 UTC by Ido Begun
Modified: 2015-02-17 08:28 UTC (History)
9 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 08:28:34 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Ido Begun 2013-06-23 13:07:32 UTC
Description of problem:
Currently there's no way to view/edit the timezone property of a template in API, while it's possible in UI.
Since everything that can be done in UI should be also be available in API, we should have access to this property in API.

Version-Release number of selected component (if applicable):
rhevm-3.2.1-0.31

How reproducible:
100%

Steps to Reproduce:
GET request on template

Actual results:
Template has no timezone property.

Expected results:
<template ...>
...
<timezone>...</timezone>
...
</template>


Additional info:
This property exists for VM's in both UI and API.

Comment 4 Juan Hernández 2014-07-11 10:13:50 UTC
I'm checking this with latest upstream 3.5 master, and it works for me. I'm moving to MODIFIED so that QE can check it works with the next downstream release.

Comment 5 Pavel Novotny 2014-08-12 11:19:21 UTC
Verified upstream in ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch (rc1).

REST API now exposes the time zone attribute. Applies for templates of all OS types.

GET /ovirt-engine/api/templates/<uuid>/ returns:

<template href="/ovirt-engine/api/templates/<uuid>">
...
  <timezone>America/Anchorage</timezone>
...
</template>

Comment 6 Omer Frenkel 2015-02-17 08:28:34 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.