Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 97464 - FQDN determined incorrectly in %post
Summary: FQDN determined incorrectly in %post
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: EasyFix-Tracker
TreeView+ depends on / blocked
 
Reported: 2003-06-16 11:43 UTC by Nils Philippsen
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-04-18 08:47:05 UTC


Attachments (Terms of Use)

Description Nils Philippsen 2003-06-16 11:43:46 UTC
Description of problem:

To install a server key, the FQDN is determined as the output of `hostname`.
While this works with a standard installation, many people rather have only the
host part as hostname and do the mapping via /etc/hosts or DNS.
This way, only the hostname and not the FQDN is used in the keys/certs.

Version-Release number of selected component (if applicable):

2.0.40-21.3

How reproducible:

Always.

Steps to Reproduce:
1. Set hostname to e.g. 'host', not 'host.domain.tld'
2. Install mod_ssl

Actual results:

See above.

Expected results:

FQDN in keys/certs.

Additional info:

make the line:

FQDN=`hostname`

in %post read:

FQDN=`hostname -f`

Comment 1 Joe Orton 2004-01-05 22:39:37 UTC
Looking at this for FC2... hostname -f is more risky, since it
actually does a DNS lookup on the system hostname, and this may all
happen at anaconda-time.  Since the end result is just a self-signed
cert of limited value anyway, I'd be inclined to stick with the status
quo.

Any compelling arguments?

Comment 2 Joe Orton 2004-04-18 08:47:05 UTC
WONTFIX without compelling arguments due to risk of a DNS lookup at
%post time.


Note You need to log in before you can comment on or make changes to this bug.