Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 97409 - redhat-config-network failed when started from command line
Summary: redhat-config-network failed when started from command line
Keywords:
Status: CLOSED DUPLICATE of bug 88147
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-14 20:18 UTC by Kim D. Dimick
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:56:43 UTC


Attachments (Terms of Use)

Description Kim D. Dimick 2003-06-14 20:18:17 UTC
Description of problem:

The redhat-config-network program failed with an Exception Occured error popup.

This is the from the exception occured window and a second part that happened
when I save the output to a file.  This system was upgraded from 7.3 to 9.0. It
was not a re-install.
This is the output from the Exception window:

Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py:137:sear
ch:TypeError: expected string or buffer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/gui/maindialog.py", line 154, in __init__
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/gui/maindialog.py", line 225, in load
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/gui/maindialog.py", line 232, in loadDevices
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/NCDeviceList.py", line 210, in getDeviceList
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/NCDeviceList.py", line 117, in load
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/plugins/NCDevWireless.py", line 34, in load
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/NCWireless.py", line 52, in load
  File "/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py", line
137,in search
    return _compile(pattern, flags).search(string)
TypeError: expected string or buffer

Local variables in innermost frame:
pattern: ^s:
flags: 0
string: None

Second output after the save to file button was depressed.
Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/lib/python2.2/site-packages/rhpl/exception.py:280:handleExcepti
on:TypeError: generic_error_dialog() got an unexpected keyword argument 'dialog_
type'
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 169, in ?
    handleException(sys.exc_info(), PROGNAME, PRG_VERSION)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 280, in handle
Exception
    dialog_type = "info")
TypeError: generic_error_dialog() got an unexpected keyword argument 'dialog_typ
e'

Local variables in innermost frame:
fs: <rhpl.exception.FileSelection instance at 0x86a04c4>
type: exceptions.TypeError
text: Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py:137:sear
ch:TypeError: expected string or buffer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/gui/maindialog.py", line 154, in __init__
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/gui/maindialog.py", line 225, in load
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/gui/maindialog.py", line 232, in loadDevices
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/NCDeviceList.py", line 210, in getDeviceList
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/NCDeviceList.py", line 117, in load
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/plugins/NCDevWireless.py", line 34, in load
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/net
confpkg/NCWireless.py", line 52, in load
  File "/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py", line 137, 
in search
    return _compile(pattern, flags).search(string)
TypeError: expected string or buffer

list: ['Traceback (most recent call last):\n', '  File "/usr/sbin/redhat-config-
network-gui", line 154, in ?\n    window = mainDialog()\n', '  File "/usr/src/bu
ild/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindia
log.py", line 154, in __init__\n', '  File "/usr/src/build/226257-noarch/install
/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py", line 225, in loa
d\n', '  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-netw
ork/netconfpkg/gui/maindialog.py", line 232, in loadDevices\n', '  File "/usr/sr
c/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDevic
eList.py", line 210, in getDeviceList\n', '  File "/usr/src/build/226257-noarch/
install/usr/share/redhat-config-network/netconfpkg/NCDeviceList.py", line 117, i
n load\n', '  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config
-network/netconfpkg/plugins/NCDevWireless.py", line 34, in load\n', '  File "/us
r/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCW
ireless.py", line 52, in load\n', '  File "/usr/src/build/228093-i386/install/us
r/lib/python2.2/sre.py", line 137, in search\n    return _compile(pattern, flags
).search(string)\n', 'TypeError: expected string or buffer\n']
progname: redhat-config-network
value: expected string or buffer
tb: <traceback object at 0x867062c>
extxt: ['TypeError: expected string or buffer\n']
version: 1.2.0
t: search
file: /rc: -5
.0: (<class exceptions.TypeError at 0x81166b4>, <exceptions.TypeError instance a
t 0x86a104c>, <traceback object at 0x867062c>)
tblast: ('/usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py', 137, 'se
arch')
out: <closed file '/home/dimick/redhat-config-network-failure.txt', mode 'w' at 
0x86b1b68>
home/dimick/redhat-config-network-failure.txt




Version-Release number of selected component (if applicable):

redhat-config-network-1.2.0-2


How reproducible:
this happens every time I try to run the program

Steps to Reproduce:
1.run redhat-config-network from the command line in a xterm window

2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Harald Hoyer 2003-06-17 14:07:43 UTC
please get the update from:
http://people.redhat.com/harald/redhat-config-network/

*** This bug has been marked as a duplicate of 88147 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:56:43 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.